Exchange 2007 & Outlook Anywhere

Hi,

I have a problem with the autodiscover service changing server names all the time.

My setup:
One domain spread across 3 separate sites each with an exchange 2007 serer and AD server connected via VPN. Each Exchange server has the following roles: HUB Transport, Client Access and Mailbox. I have the correct certificate installed and it can resolve autodiscover.domain.com, site1.domain.com, site2.domain.com and site3.domain.com +mail etc... The autodiscover A record points to site1 both externally and internally.
The problem Im having is that autodiscover works both internally and externally but then at random times it will change clients outlook setting to one of the other servers\sites that there mailbox does not reside on. E.g. A remote user with a mailbox on site1\server1 connects and outlook works and discovers the correct servers site1.domain.com then a week later they will open outlook and it will constantly prompt the user for a password but wont authenticate, if I check the outlook settings I see its been changed to site2.domain.com instead of site1.domain.com where there mailbox sits. If I change it back to site1.domain.com then they can work again as normal. There is no pattern to when it changes and which servers it will change to, sometimes its site 1, then site3 then site1 again or site2...
 
Is there away to specify that a user on a certain mailbox store always connects to that server? Or remove a rule to say that they can use any server name within outlook as they are part of the same domain?

If you require any more info or if I havent made myself clear please let me know. Thanks in advance for your help.
brad-willsonAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
progjmConnect With a Mentor Commented:
You can also use this command to keep the value from automatically populating

Set-OutlookProvider -Identity EXPR -CertPrincipalName msstd:$null
0
 
progjmCommented:
What is the CN or your certificate? Is that the same value that have have for msstd:?
0
 
brad-willsonAuthor Commented:
Thanks for your reply. The CN is different to the msstd:
I use a different msstd server for each site that a users mailbox resides on, is that not correct?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
progjmCommented:
Do you have a test Exchange server you can try this command on

Set-OutlookProvider -Identity EXPR -CertPrincipalName msstd:(mail or whatever).domain.com
0
 
brad-willsonAuthor Commented:
Thanks again, I dont have a test exchage server to run that command on. If I run it on our live server would running that command on only one server affect all 3 servers or would it only change the settings on the exchange server that Im running it on?
0
 
progjmCommented:
Should only chnage the settings on the one server
0
 
progjmCommented:
How did this go?
0
 
brad-willsonAuthor Commented:
Hi,

I made the change Set-OutlookProvider -Identity EXPR -CertPrincipalName msstd:$null and it appears to work. Thanks for your help. I would like to leave it for a week or so as the problem seems to be ok and then comes back. If it continues to work I will accept your solution! Thanks again
0
 
progjmCommented:
Glad I could help, let me know if you need any more assistance
0
 
progjmCommented:
How is everything working?
0
 
progjmCommented:
Have not heard back from you, how are things working
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.