IIS will not start - corrupt metabase.xml

After doing routing Windows updates and restarting, IIS did not start. We discovered the root of the problem is the metabase.xml file.

Tried deleting, renaming, moving but file is corrupt and nothing (including 3rd-party utilities) seems to work. ("File is unreadable or directory is corrupt.") Tried to restore from backup, with no success. Deleted and re-installed IIS, then applied SP2 hoping that might re-install, but no.

Along with the IIS event error, we also get NTFS error 55. Tried CHKDSK /f/r and /x with no success (volume locked). System is a RAID 5, SBS Server 2003 SP2.

IIS error: Event ID 7023 the IIS admin service terminated with the following error: File or directory is corrupt and unreadable.

NTFS Event ID 55: The file system structure on the disk is corrupt and unusable. Please run CHKDSK utility on volume.

The volume we are trying to fix is the system drive. Everything else is working fine except IIS and Exchange Server.

How can we correct the NTFS error and get IIS to start without doing a full system restore? And/or, how can we delete the corrupt metabase.xml file?

Any help from anyone on this issue will be greatly appreciated. We've been banging our heads against the wall for a full day.
jjanknegtAsked:
Who is Participating?
 
jjanknegtConnect With a Mentor Author Commented:
Thanks everyone for you help but we just ended up rebuilding all systems
0
 
MesthaCommented:
If you removed IIS, and then didn't install Exchange then you have broken Exchange. Exchange doesn't like having IIS pulled from under it.

There is a correct procedure for removing IIS when Exchange is involved:
http://support.microsoft.com/kb/320202

Considering what you have already done, I would suggest that you follow it, ensuring that you remove everything connected to IIS.
After reinstalling IIS and Exchange, re-run the Configure Internet and Email wizard in SBS.

Simon.
0
 
srepphanCommented:
If you haven't already, try configuring CHKDSK to run at boot-time. This way it can scan for bad sectors on the system drive before it is locked. I will assume you already did this as it should prompt you to try a boot-time scan if the volume is the system partition.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
jjanknegtAuthor Commented:
Thanks for the quick replies. Yes, we did run CHKDSK several times on reboot, in safe mode, with a variety of switches. Same result; couldn't unlock the volume.

Simon, we can't proceed to re-installing Exchange until IIS will start, and we can't get IIS to work (even after reinstalling it) with the corrupt metabase.xml file still "stuck" in the inetsrv folder. It's resisted every attempt to delete, move, rename, overwrite, edit or work with it in any way.

We may be re-installing SBS this weekend if we can't find a fix.
0
 
srepphanCommented:
You are probably dealing with a corrupt MFT. The only solution that I know of is to backup everything, reformat, and then restore everything BUT the metabase.xml file.
0
 
MesthaCommented:
If you remove IIS, then reboot the machine, then the lock on the files should be released. It is important that you reboot to release the locks.

Simon.
0
 
srepphanCommented:
The problem is not with locks. Error 55 is a corrupted file and/or corrupted MFT fragment.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.