Solved

Unable to connect Exchange with Outlook using RPC over HTTP on Small Business Server 2003

Posted on 2009-05-07
7
222 Views
Last Modified: 2012-05-06
Running Windows 2003 Small Business Server for Exchange purposes only. Most client computers are not connected to the domain as they may be members of other domains and work offsite. Otlook clients can connect to the Exchange server when they are connected to local network. Using Outlook Web Access from remote location with web browser works with both HTTP and HTTPS, despite the certificate warning as it is not issued by a trusted authority.
However, the Outlook clients are not able to connect to the server when they are outside using Outlook HTTP connection.
0
Comment
Question by:radio12
  • 5
7 Comments
 
LVL 22

Expert Comment

by:mutahir
ID: 24329648
RPC over HTTP works by having an Exchange Server front-end computer configured as an RPC proxy server. This RPC proxy server then specifies which ports to use to communicate with the network's domain controller, global catalog (GC) servers, and all Exchange servers that the client user requires. The Exchange group in your organization must first deploy RPC over HTTP for the Exchange servers you use, and then you can configure user accounts that access those Exchange servers to use RPC over HTTP.
http://office.microsoft.com/en-gb/help/HA011402731033.aspx
Check the above link and see if you are meeting all requirements, have you added the certificate in every clients computer needing an access outside your local lan ?
Hope this helps
0
 

Author Comment

by:radio12
ID: 24329718
IIS virtual web site Rpc has Anonymous access alllowed, Integrated Windows authentication and Basic authentication are enabled. default domain not set. All ip addresses are granted access. Certificate is self-issued by the server with external domain name.

Could it be a certificate issue?

in HKLM/Software/Microsoft/Rpc/Rpcproxy ValidPorts have enabled ports 593, 6001, 6002, 6004 for both local and external domain names.
0
 

Author Comment

by:radio12
ID: 24329883
Can anyone help me how to install the certificate on client computers correctly?

Thanks mutahir! I found out that my computer registry was missing that subley completely:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\RPC
Value name: EnableRPCTunnelingUI
Value data: DWORD

That did not solve the problem, however.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:radio12
ID: 24330062
When trying to connect with Outlook 2003 using HTTPS, it shows Trying to connect on status bar. Then just Offline. Using HTTP just keeps prompting for password again and again.
0
 
LVL 65

Accepted Solution

by:
Mestha earned 500 total points
ID: 24330207
This is your problem:  "Rpc has Anonymous access allowed"
That shouldn't be set as it means the anonymous account is used for access.

Run the Configure Internet and EMail wizard and choose to enable Outlook over the Internet. That will set the permissions correctly on everything for you.

Simon.
0
 

Author Comment

by:radio12
ID: 24330430
Thanks, Simon.
I  tried running that configuration Wizard enabling Outlook over the Internet.
After that, disbled Anonymous access for Rpc on IIS.

But still no success when trying to connect, sorry.

Any ideas?
0
 

Author Comment

by:radio12
ID: 24331149
I think it was certificate issue. When running the Configure Internet and EMail wizard one more time I created new certificate for IIS. That certificate differs from the previous one in one way: hte issuer has the same FQDN as the site it is issued to. After installing that certificate on client computer I was able to access Oulook Web Access without certificate errors.
After that Outlook client was able to connect too. I just had to use domain\username as user name when looging on. If someone knows fix for that minor isuue, the users will be happier.
Credits to Mestha, running Internet and EMail wizard was finally the solution, although probably not the way as expected.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

815 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now