Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 937
  • Last Modified:

Offline File Sync - Files sync properly, but access is denied when they leave the network

Hello!!!

We're running a Windows 2003 Domain, where offline files are synced from their network 'U:" drive (personal drive) and redirected to their My Documents folder.

We're getting a new laptop ready for a user.  The laptop syncs without any errors, however when you disconnect the laptop from our network they cannot access their files.  To be more precise, if they open My Documents, all of the files are listed, and when you double-click on them the corresponding program opens (If it's a .doc file, MS Word opens)  but then it tells us the File no longer exists (that's an MS Word error).  If we try a .pdf file, Adobe Reader opens and says access denied (An Adobe reader error).  If we try to copy any of the files to the desktop or to a different location it says Access denied.

Nothings changed in our network.  She had an old laptop that synced up just fine previously.  We've double-checked permissions (Authenticated users have access (Full)  to the share, but only each individual user has rights to their folder (through security)

A few things I noticed:  It does a complete sync every time...no matter what files are changed, it seems to recopy every file.   Also, as soon as the computer is plugged back into the network they have full access to their folders, it does a full sync, and it seems everything works fine.  As well, if the user opens a specific file, then they go 'offline', they will have access to that file, but none of the others.  (It would be extremely time consuming to open every single file and hope it worked...I thought of that already :-\ lol)

I've Deleted her local profile on the computer and created a new one (thinking that may be it) But it did not help.

Thanks for the help in advance!!!
0
Bocestechguy
Asked:
Bocestechguy
3 Solutions
 
sfarazmandCommented:
Turn of roaming profiles for the user. Copy her files to another location. Delete here folder on the network as well as her local profile. Create a new home (share folder for the user). Create a new local profile. Have her log in. Reboot. Copy the files back and make sure to check the folder permissions, set up roaming profile again.
0
 
JohnBusiness Consultant (Owner)Commented:
You may have to connect up the user and then uncheck all the sync marks on the file (properties of the file). I recall having to do that on my Vista laptop to make the synchronization process work half decently. I chose the last phrase carefully because I could corrupt the synchronization at the drop of a hat. Note also the past tense here.

I finally tired of it completely. I purchased and use SyncBack Pro. Vastly more robust, more reliable, easier to use, independent of file type, and much faster. I just never looked back.
... Thinkpads_User
0
 
sfarazmandCommented:
Sorry, was thinking wrong thing. I've had vista users who get stuck in a file sych error. We had to remove the sych correct the errors, blow away the profile and recreate it.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
busjahnCommented:
I would disagree with sfarazmand, given the description in your question, you are currently using offline files.  Roaming profiles only copy files which have changed since the last synchronization, and this is usually the desired action.   I don't believe that offline files are intended for use in user profiles.
0
 
BocestechguyAuthor Commented:
When you say blow away the profile, what do you mean exactly??
0
 
BocestechguyAuthor Commented:
I've deleted their profile on the computer: System Preferences>Advanced tab>User Profiles >Advanced clicked on the profile and deleted it.    It's doing the same thing.
0
 
sfarazmandCommented:
By blowing away the profile i mean logging on as local admin and deleting the user folder under Documents and Settings.
0
 
BocestechguyAuthor Commented:
I had tried that previously.  I finally ran across a page that helped:

http://support.microsoft.com/kb/230738

Pressing Ctrl-Shift then click delete in the Offline File Settings (Explorer>Tools>Folder Options>Offline Files Tab)

After I did that and rebooted it started working.

I'll split up the points for the effort :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now