iPhone sync with Exchange 2003 SP2

I know there are other post out there but I for the life of me I cannot solve getting my new iPhone 3G to sync with our MS Exchange 2003 Server SP2.  I have followed every instruction out there I can find from in here, MS Sites, and Apple sites as well.

I have RPC over HTTP set up
I have Activesync set up
Mobile Access is Enabled
I have tried Enabling and disabling the IMAP protocal for just me as I am the only iPhone user.
My Certificates are all up to date and the are NOT selfsigned.
I have made the updated registry entries.
Restarted the Exchange server.

The only conclusion I can come to is I am not entering the server name correctly on the iPhone itself.  I have tried sever different names and IP's and received several different results, form the certificated does not match, I accept, and then the connection fails, a Could not connect to the Exchange Server, to no erros and the iPhone just continues to triy and connect with no results.

I expected to run into problems here but I am out of ideas now.
SD_BoltsAsked:
Who is Participating?
 
MesthaConnect With a Mentor Commented:
The name needs to match your certificate.
So if your certificate is host.example.com that is what you enter. IP address or whatever will not work.

Test the setup using the Microsoft test site:
https://testexchangeconnectivity.com/

Simon.
0
 
SD_BoltsAuthor Commented:
I think this might do it, I will do this first thing in the morning and post back.
0
 
LozanoSmithCommented:
Also there I have seen cases where the username had to consist of the domainname/username. But I believe Simon has pointed you in the right direction.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
SD_BoltsAuthor Commented:
Thanks a million, the link fixed everything, I do not know how I did not come accress this before, but as soon as I set it up, all my information came flooding in.  Thanks Again.
0
 
crcsupportCommented:
In my case, it was the form field authetication problem. It should be disabled as Apple Enterprise deployment stated.
0
 
SD_BoltsAuthor Commented:
The Form Field Authetication was also a problem for me, but when I disabled it, it blocked people from accessing our OWA from outside the office.  Using the answer above allowed me to create a secondary virtural server strictly for mobile devices.

It is important to point out that I am only using a single exchange server in a back end environment.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.