Solved

Named pipes provider error 40, but only for other users!

Posted on 2009-05-07
12
303 Views
Last Modified: 2012-05-06
I have a winforms app in VB.NET 2008 with a SQL Server 2008 back end on an internal server on our network.  There is no firewall on the server as it is not exposed to users outside the network.  The software has worked great until this morning.  I checked and found that the server had been rebooted due to some 'upgrades' and then it connected to the network again.

The software works perfectly for me, but my two other users get the error in the attached screen shot.  I have tried all day to troubleshoot the issue to no avail.  I have disabled shared memory, I have disabled named pipes, I have gone back and enabled both.  Any ideas?
ErrorMessage.doc
0
Comment
Question by:pigparent
  • 6
  • 4
  • 2
12 Comments
 
LVL 15

Expert Comment

by:mohan_sekar
ID: 24330035
Try this - if you are accessing the server by it's name, try by it's IP address.
0
 
LVL 1

Author Comment

by:pigparent
ID: 24330091
Good suggestion though my connection string refers to it by IP address.  I wouldn't know a named pipe from a sewer pipe, frankly.
0
 
LVL 15

Assisted Solution

by:mohan_sekar
mohan_sekar earned 75 total points
ID: 24330199
And the others also refer to it by IP address?

One other way I could think of is creating an alias as below

Open SQL Server Configruation Manager, right click on 'Aliases' and select 'New Alias'. Enter alias name, port # of your DB server, protocol (TCP/IP) and server name.
Restart your program and see if it helps
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 69

Assisted Solution

by:Qlemo
Qlemo earned 75 total points
ID: 24330318
If there are some issues with TCP, like name resolution problems (does not apply if you use IP addresses, as you told us), delays in establishing connections, and alike, Named Pipes are (tried to be) used even if they are disabled on client and/or server side. Named Pipes cannot be established using IP addresses, only with (NetBIOS) names.

If you can't get around the cause, which is always a network issue, use the workaround to allow Named Pipes, and connect with name instead of IP.

0
 
LVL 1

Author Comment

by:pigparent
ID: 24334953
Thanks to both of you.  I have tried both suggestions and neither has worked.  I stepped through the code and replaced my username with theirs and it worked fine on my machine.  Only when I had one of the users log into my machine and I stepped through the code did I get the error shown in the screenshot.  Could it be a user account issue?  Something installed on my machine that's not present on theirs...or vice-versa?  Thanks!
0
 
LVL 69

Expert Comment

by:Qlemo
ID: 24335484
This smells like missing access rights for Named Pipes, which are done by a similiar technique as file shares. If those users would be admins, it will work, if I'm right.
0
 
LVL 1

Accepted Solution

by:
pigparent earned 0 total points
ID: 24338094
Thanks, I tried making one the users an admin and that also did not work.  I think I will spend the weekend trying to convert this software from SQL Server to MySQL.
0
 
LVL 69

Expert Comment

by:Qlemo
ID: 24338145
And Named Pipes are enabled?
0
 
LVL 1

Author Comment

by:pigparent
ID: 24338267
Yes they are, and I have confirmed that the pipe name matches the 'listening' pipe in the log file.  Thanks again for your help!
0
 
LVL 69

Expert Comment

by:Qlemo
ID: 24350178
I'll give up. If MySQL is your way, go it.
0
 
LVL 1

Author Comment

by:pigparent
ID: 24355721
Yeah, that's kinda where I am with it.  I think the server administrator disconnected it from the domain and that's what's causing the problem.  He won't put it back and nothing else I can find is working.  MySQL works every time for me, so I guess I'm left with no choice.

Thanks for trying; I really appreciate it.
0
 
LVL 1

Author Comment

by:pigparent
ID: 24410529
All, after much research i was able to fix the problem by resetting the sa password.  I had read that some strange things can happen, and that resetting the sa password might help.  I tried it, and all my problems vanished.  Go figure.
0

Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The ECB site provides FX rates for major currencies since its inception in 1999 in the form of an XML feed. The files have the following format (reducted for brevity) (CODE) There are three files available HERE (http://www.ecb.europa.eu/stats/exch…
Hi all, It is important and often overlooked to understand “Database properties”. Often we see questions about "log files" or "where is the database" and one of the easiest ways to get general information about your database is to use “Database p…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

816 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now