Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3162
  • Last Modified:

How to import PST files to Exchange 2007

I am trying to import PST files that I have exported from Exchange 2003.
I have a vista32 bit client with exchange management tools and powershell installed.
I have ensured that the user account has exchange organisation level permissions and local administrator permissions.
When I run the following command:
Get-Mail -Database "mailbox database" | Import-Mailbox -PSTFolderPath z:\
(z:\ is mapped to the location of the pst files).
I get the following error:
The log file directory 'C:\Program files\Microsoft\Exchange Server\logging\Migration Logs' does not exist.
Has anyone else had this problem before and found the solution? I am mid-deployment and urgently need a response. I cannot find any sense on the net about it so I am assigning full points.
0
tdhfox21
Asked:
tdhfox21
  • 7
  • 4
  • 3
  • +3
2 Solutions
 
tdhfox21Author Commented:
One other thing.... Im an aussie.... So I am generally sleeping while most of you are working and vice-versa... so give me a chance to reply :)
0
 
Steven WellsSystems AdministratorCommented:
How about just simply.

import-mailbox -identity username@yourdomain.local -PSTFolder path Z:\username.pst

Steven
Sydney
0
 
tdhfox21Author Commented:
To StevenWells99:

Will give it a shot and report back.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
tdhfox21Author Commented:
To StevenWells99:

I gave it a go and got the same error. I don't think the syntax is the problem. I believe it is more likely a permissions or configuration issue with this log file.
0
 
Steven WellsSystems AdministratorCommented:
I wonder, does that folder actually exist on your machine, if not, can you create it?

On my server i have this folder path:

C:\Program Files\Microsoft\Exchange Server\Logging\MigrationLogs

0
 
tdhfox21Author Commented:
Comment. No it did not exist. And I did not initally have permissions to access the parent folders. I have since added my user account to the exchange organisation administrators group  - that gave me the permissions and added the folder.
A few extra points:
This is a brand new SBS 2008 deploy which is why I am wondering about config.
I have tried this both directly on the server (I know that is not the done thing - but I'm getting desperate), and on the 32bit workstation. Both locations give me exactly the same error.
0
 
-alvin-Commented:
does the account you are using to import have full access to the target mailbox?  
0
 
tdhfox21Author Commented:
Alvin:

I believe so. I have made the account a member of the local administrators group and the exchange organisation administrors group.
0
 
-alvin-Commented:
i'm assuming you have outlook 2003 or better installed on your vista machine too.
0
 
-alvin-Commented:
being a member of the local admin grp and/or the exch org admin grp doesn't necessarily give you full access to the mailbox.  check to see if they do indeed have rights.  if not, add "full access" for that user on the target mailbox to test.
0
 
-alvin-Commented:
0
 
Steven WellsSystems AdministratorCommented:
Ensure that the account you are using to run the exchange console tool is not a domain admin this will have a deny. However, that error is strange. I just tried to export/import a mailbox with an account that didn't have rights and got a MAPI error failure, not a folder error. .
Are you using the exchange tools from Exchange 2007 Sp1?
0
 
tdhfox21Author Commented:
Ahhh.... the account I am using IS a domain admins! That may be it. I will remove those permissions for the test and see how it goes. My day has run out now so it wont happen until Monday. Touch back with me then.
0
 
GusGallowsCommented:
Also, make sure your account is mail-enabled. To work with PST files, I think you have to use an account with a mailbox associated with it.
0
 
ElnatanExpertCommented:
I had the same problem, but managed to get it working by right-clicking Exchange Management Shell, and selecting Run As Administrator on the Vista Machine.
Also make sure that the database name includes the servername ie. "myserver\mailbox database"
0
 
tdhfox21Author Commented:
the key to this ws permissions... you need to ensure the account you use only is a member of the required security groups as other groups often have explicit denied permissions that stop the process working
0
 
StussyexpertCommented:
This is a uac problem!
Solution 1:  Run powershell as administrator
Solution 2: If you run powershell as an other user, give full permissions for this user to the key : HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\Exchange Migration
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 7
  • 4
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now