Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Cisco SDM wont load

Posted on 2009-05-07
2
Medium Priority
?
1,230 Views
Last Modified: 2013-12-27
i have a Cisco 877 modem router which i have factory reset. i have enabled HTTP and HTTPS on the router using a console cable, to allow me to use SDM. i have installed SDM v24 on both the computer and router, and have the lastest java, IE6 (with popup blocker off and all security settings at low. the SDM launcher shortcut works, and opens IE6, and does the usual asking for password thing. click on the yellow bar at the top to allow active x, brting up another windows (as normal so far). the next window appears, but it doesnt load the actual SDM configuration window. any ideas?
Building configuration...
 
Current configuration : 3891 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
 --More--         ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1 
   lease 0 2
!
!
no ip domain lookup
ip domain name yourdomain.com
!
!
crypto pki trustpoint TP-self-signed-4164049743
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4164049743
 revocation-check none
 rsakeypair TP-self-signed-4164049743
!
!
crypto pki certificate chain TP-self-signed-4164049743
 certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
 --More--           31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 34313634 30343937 3433301E 170D3032 30333031 30303137 
  32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 31363430 
  34393734 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100CA1E 2C4ACC46 67B9001A 8970FD1B 757CFBB5 852D17B4 CD289ACC 7F3DB528 
  B52DDA4E 347A60DB 1FF21C4E 3520F22B DCFCCDFF 38AE636F 6A6C620F 54EE0F0C 
  01374B6B 86CD8FCF 224209BB 640E40DB 891614D7 5EE018B0 CBAF5947 2DC0C608 
  2C96A076 857B3904 587D2A2D D95C20F6 2629CD24 BED339D0 0F66A015 B6DD4D25 
  31B70203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603 
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D 
  301F0603 551D2304 18301680 148915A2 3054AE0B 3E6C5692 83AF018E A2395C55 
  18301D06 03551D0E 04160414 8915A230 54AE0B3E 6C569283 AF018EA2 395C5518 
  300D0609 2A864886 F70D0101 04050003 818100A4 322B3CF3 174D011B 60C34303 
  E807EC97 C61027D0 48432AE3 55F4065B 0A04E05F 53840DB8 C810CD88 D0E03571 
  17696150 055760C8 A25B42E0 2B70287A ED8CE744 35D10378 D03DDA68 37F11FF5 
  67B1BD2D 1D29A387 5972EF0E 80A7B6A3 BF1F90B9 EC67B098 8FC24836 5583D128 
  5EB74E48 3D05F4F4 F71245B5 0C3314D2 A68737
  quit
username cisco privilege 15 secret 5 $1$tzkU$gE9K2LJwwYKl0n9Q3234j1
username **** privilege 15 password 0 ****
!
! 
 --More--         !
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto 
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 10.10.10.1 255.255.255.248
 ip tcp adjust-mss 1452
!
ip classless
 --More--         !
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
no cdp run
!
control-plane
!

Open in new window

0
Comment
Question by:wait1
  • 2
2 Comments
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 2000 total points
ID: 24332630
Hi,

Latest java is not compatible with Cisco SDM. Please uninstall it and install JRE 5.0 instead. In facctthe screen after you enter password s just where SDM Java application kicks in and apparantly it crashes in Java 6.0. After you install JRE 5.0 it will then work.

Also check your language settings in your desktop os. Some languages (like Turkish) prevent it from loading. Set it to an English if it is not already set so.
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24332703
BTW Remove the config file here it includes all your secrets and certificates etc.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Before I go to far, let's explain HA (High Availability) and why you should consider it.  High availability is the mechanism used to provide redundancy to any service at the same site and appears as a single service to the users of that service.  As…
Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

877 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question