Solved

Change to full duplex required !

Posted on 2009-05-07
16
1,060 Views
Last Modified: 2012-06-21
Hi there,
Scenario is given below. Goal is to get the switchport working in full duplex, its in half duplex right now
Topology can be seen in the diagram below. Basically, its a connection between two routers at 2 different sites, Telstra and the other AAPT. AAPT router terminates into a LAN 2960 Cisco switch and then onto the r2_core router (Telstra). Upon checking that switch port where AAPT terminates, it is operating in half-duplex mode. The switch port is also showing errors in show interface gig 0/20 counter errors. How can I make this switchport operate in full duplex ? I've enabled bpdu guard commands on my switch port coz the ISP shuts down the port if its not enabled. Given below are the configuration on these devices and show commands.
 

LANSwitch1#sh running-config interface gigabitEthernet 0/20

Building configuration...
 

Current configuration : 133 bytes

!

interface GigabitEthernet0/20

 description CrossConnect-AAPT

 spanning-tree bpdufilter enable

 spanning-tree bpduguard enable

end
 
 
 

r2_core#sh running-config interface gigabitEthernet 0/0.1

Building configuration...
 

Current configuration : 108 bytes

!

interface GigabitEthernet0/0.1

 encapsulation dot1Q 1 native

 ip address 172.16.0.66 255.255.255.248

end
 
 

AAPT#sh running-config interface ethernet 1/0

Building configuration...
 

Current configuration : 120 bytes

!

interface Ethernet1/0

 description Cross-Connect-to-Telstra

 ip address 172.16.0.68 255.255.255.248

 full-duplex

end
 
 
 
 

Show Commands:
 

AAPT#sh interfaces ethernet 1/0

Ethernet1/0 is up, line protocol is up

  Hardware is PQUICC Ethernet, address is 000d.28dc.4de4 (bia 000d.28dc.4de4)

  Description: Cross-Connect-to-Telstra

  Internet address is 172.16.0.68/29

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 16/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 10BaseT

  .... 
 

LANSwitch1#sh interfaces status

Gi0/20    CrossConnect-AAPT  connected    1          a-half  a-100 10/100/1000BaseTX
 

LANSwitch1#sh interfaces gigabitEthernet 0/20 counters errors
 

Port        Align-Err    FCS-Err   Xmit-Err    Rcv-Err UnderSize

Gi0/20              0          0          0          0         0
 

Port      Single-Col Multi-Col  Late-Col Excess-Col Carri-Sen     Runts    Giant

s

Gi0/20          4915       372      2847          0         0         0

Open in new window

figure.JPG
0
Comment
Question by:nabeel92
  • 7
  • 5
  • 3
  • +1
16 Comments
 
LVL 22

Expert Comment

by:rickhobbs
Comment Utility
Try fixing the speed on Gi0/20 to 10. The auto-neg is probably causing the error.
0
 
LVL 22

Expert Comment

by:rickhobbs
Comment Utility
Reference:

http://www.cisco.com/en/US/tech/tk389/tk214/technologies_tech_note09186a0080094781.shtml#when

One of the most common causes of performance issues on 10/100 Mb Ethernet links occurs when one port on the link operates at half-duplex while the other port operates at full-duplex. This occurs when one or both ports on a link are reset and the auto-negotiation process does not result in both link partners having the same configuration. It also can occur when users reconfigure one side of a link and forget to reconfigure the other side. Both sides of a link should have auto-negotiation on, or both sides should have it off. Cisco recommends to leave auto-negotiation on for those devices compliant with 802.3u.

Many performance-related support calls are avoided if you correctly configure auto-negotiation. Many Catalyst Ethernet switching modules support 10/100 Mb and half-duplex or full-duplex. Exceptions include the Ethernet Group switch modules. The show port capabilities {mod_num} | {mod_num/port_num} command shows if the module you are working on supports 10/100 Mb and half-duplex or full-duplex. This document uses two WS-X5530 Supervisor Engine IIIs, each with two optional uplink 10/100 BaseTX Ethernet ports installed.
0
 

Author Comment

by:nabeel92
Comment Utility
at the moment, it is 100 . So you recommend i should manually change the speed to 10 and it would change to full duplex ?
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
How can I make this switchport operate in full duplex?



config t

 int g0/20

 duplex full

end

Open in new window

0
 

Author Comment

by:nabeel92
Comment Utility
Both the mentioned commands resulted in int gig 0/20 appearing as "NOT connected" when I did show interface status ... I first set the duplex to full and then speed to 10 but it just brought that port down ... Changed the port already but didnt made any difference !
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Are you saying that when the switchport is set to half duplex it show "connected" but at full duplex it shows "not connnected"?
0
 

Author Comment

by:nabeel92
Comment Utility
Yes ... thats exactly what happens !
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
How are the AAPT router and the 2960 switch connected? How far apart are they?
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:nabeel92
Comment Utility
ok .. they both are in the same data centre but on different levels ... One is on Level 1 and other is Level 2 .... In between AAPT and 2960, it obviously goes thru an ISP Layer 2 switch which is transparent .. So its like
AAPT (ethernet (full duplex/10 mbps)) <----> ISP Switch <---> Layer 2 Switch (gigabit ethernet (half/100 mbps)

Given below is an output when i do show interface gig 0/20 status on switch ...

LANSwitch1#sh interfaces status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/1     BM 1/3             connected    180        a-full a-1000 10/100/1000BaseTX
Gi0/2     BMS 1/3            connected    180        a-full a-1000 10/100/1000BaseTX
Gi0/3     IB 1/3             connected    180        a-full a-1000 10/100/1000BaseTX
Gi0/4                        connected    180        a-full  a-100 10/100/1000BaseTX
Gi0/5                        notconnect   180          auto   auto 10/100/1000BaseTX
Gi0/6     RTS4 1/3           connected    180        a-full a-1000 10/100/1000BaseTX
Gi0/7     RTS1 1/3           connected    180        a-full a-1000 10/100/1000BaseTX
Gi0/8     BSL 2/3            connected    180        a-full a-1000 10/100/1000BaseTX
Gi0/9     PrivateWWW         connected    190        a-full a-1000 10/100/1000BaseTX
Gi0/10                       connected    190        a-full a-1000 10/100/1000BaseTX
Gi0/11                       notconnect   180          auto   auto 10/100/1000BaseTX
Gi0/12                       connected    180        a-full  a-100 10/100/1000BaseTX
Gi0/13    BM 3/3             notconnect   190          auto   auto 10/100/1000BaseTX
Gi0/14                       notconnect   190          auto   auto 10/100/1000BaseTX
Gi0/15    IB 3/3             connected    160        a-full  a-100 10/100/1000BaseTX
Gi0/16    RTS4 3/3           connected    160        a-full  a-100 10/100/1000BaseTX
Gi0/17                       connected    160        a-full  a-100 10/100/1000BaseTX
Gi0/18                       notconnect   160          auto   auto 10/100/1000BaseTX
Gi0/19                       notconnect   160          auto   auto 10/100/1000BaseTX
Gi0/20    CrossConnect-AAPT  connected    1          a-half  a-100 10/100/1000BaseTX
Gi0/21                       notconnect   1            auto   auto Not Present
Gi0/22    Link to Core-Route connected    trunk      a-full a-1000 10/100/1000BaseTX
Gi0/23    Link to Edge-Route connected    trunk      a-full a-1000 10/100/1000BaseTX
Gi0/24    Cross-Connect-LANS connected    trunk      a-full a-1000 10/100/1000BaseTX
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
>In between AAPT and 2960, it obviously goes thru an ISP Layer 2 switch which is transparent ..

There's your problem. Duplex (and speed) is set between interfaces. It sounds like there's something no quite right between your 2960 interface and the ISP's interface.

You'll need to coordinate with them to resolve this. From your information, it's obvious that the providers switchport is in full duplex mode (late collisions). Normally, manually setting the duplex works. But I've run into situations (an Intel switch connecting to an HP server, I think) where the duplex on one side had to me manually set while on the other it had to be set to auto.

If you haven't already tried it, you should try setting the g0/20 to "duplex auto". If that doesn't work, you'll have to talk with the ISP.
0
 

Author Comment

by:nabeel92
Comment Utility
I tried duplex auto on gig 0/20 but no luck ... i'll have a chat with ISP (Telstra) now and see if they can advise anything ... but they are never helpful !
0
 

Author Comment

by:nabeel92
Comment Utility
just had a chat with telstra ... the guy checked ports at their switch which were both hardcoded to full duplex/100 mbps ... he said he could see the CRC errors / collisions at his end ... He has escalated it but i doubt if that would help ...
I actually had a similar issue where i used a switch between a PIX firewall ethernet interface and an internet link ... When i used the switch in between, it would cause it to go to half duplex, only when i eliminated the switch, it moved to full duplex ....
Now, am pretty sure that If i terminate this line from AAPT into my R2_core router directly and ditch the switch, it would cause the link to be 100 mbps/full but why would the switch create the mess and make it half duplex ?
I do know its default behavior of switch port to go into half duplex/100 mbps if it cant detect anything at other end, which is what is happening right now ..... but why would that be the case with a working cisco switch ?
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
Comment Utility
The duplex/speed determination method for the router should be the same as a switch. So there shouldn't be any difference.

Do you know what kind of switch the ISP is using?
0
 

Expert Comment

by:joebenz1980
Comment Utility
try a duplex full and speed 100 on your g/20 interface and see what happens.  
0
 

Author Comment

by:nabeel92
Comment Utility
I didnt ask the ISP about their switch but i'll ask em since their level 3 will call me back tomorrow ...
joebenz1980, ive already tried that and it shuts down the port if i do full/100 ...
0
 
LVL 22

Expert Comment

by:rickhobbs
Comment Utility
Can you disconnect the switch and see if the problem does resolve itself?
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now