Solved

ISA 2006, WPAD, IE Auto Detect - users prompted for credentials in IE

Posted on 2009-05-07
3
881 Views
Last Modified: 2012-05-06
Hi all,

I've just setup WPAD in DHCP which runs on our ISA box.  I have enabled ISA to broadcast the auto discovery info for the internal netowrk and it's all ticking along happily.

Now, with auto dtetct settings enabled in IE on any computer any user gets requested for thier AD username and password.  I would expect this on non-domain computers, but it's happening to domain members as well.  It pops up for any IE window or any other app that try to access the net.

I think I have seen this issue before and there was a registry fix for it, but that was on ISA 2004 and, despite searching high and low, I can't find that fix anywhere on the net!

Appreciate any assistance!
     
0
Comment
Question by:Schikitar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 

Author Comment

by:Schikitar
ID: 24409055
I found the registry fix I was referring to, which is basically this;

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3Proxy\Parameters]
"SkipAuthenticationForRoutingInformation"=dword:00000001

Unfortunately this had no affect and I'm still getting asked to confirm my credentials (it defaults to the local machine though, rather than the domain, ie. ISA\<username> rather than DOMAIN\<username> - not sure if that is relevant).
0
 

Accepted Solution

by:
Schikitar earned 0 total points
ID: 24417984
Okay, we found the solution in this thread - http://forums.isaserver.org/m_270016300/mpage_1/key_/tm.htm#270016317

Seems, because of the Burstek filtering software we use, we needed to create a web server publishing rule and listener (we used the non-standard port 8088 for wpad through DHCP).

That's two questions in a row I've had to solve without any assistance - it's a bit dissapointing!
0
 

Expert Comment

by:pyv4x
ID: 34493322
It was a quick fix for me. Go to Internet Option > Connection > LAN Settings. Uncheck all the boxes.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A Cisco router can be configured as a DHCP Server. There are advantages and disadvantages in making your Cisco router work as DHCP Server. Almost all the features for windows DHCP can be configured on Cisco-based DHCP server. Some of the features me…
Microsoft's ISA Server has been its pre-eminent security product for about a decade and is still regarded amongst the well-informed as one of the best software firewalls and application gateways ever released, by any manufacturer. ISA Server has bee…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question