IIS 6.0 network share permission probelm

I can't find the right persmiions on a network share to allow IUSER on SRV1 (www.domainname.com/path) to map the virtual directory /path to SVR2 (\\SVR22\sharename)
I keep getting an authentication prompt.
barnster123Asked:
Who is Participating?
 
b_levittConnect With a Mentor Commented:
Do you have a domain controller?  If so run www.domainname.com/path under a domain account rather than the local IUSR account and make sure that same account has access to \\SVR22\sharename.

If you do not have a domain controller, you have to use what's known as passthru authentication.  You need to create a mirror copy of IUSR_SRV1 user on the SVR22 computer - same username and password.  Then you grant THAT user permission to the share and filesystem you want access to.  When local accounts are involved, authentication to a separate computer is done by passing the username/password of the logged on user, if that login fails, then it will prompt you for a different user.
0
 
barnster123Author Commented:
levitt,
No I don't have a domain contraoller which would have been easier.
 Yes I've tried this method, I don't get an auth prompt any more but I do get a 500 error.
As it is the IUSR do I need a password for the user on the second server?
0
 
b_levittCommented:
Yes you need the same password for the user on the second computer.  But I did forgot about IIS controlling the password for the IUSR account.  It might be best to create a new user for the site to run under and forget about the IUSR account.  You can even make this an administrator account while the site isn't live to focus on the authentication related issues and temporarily eliminate permission related issues.  Just make sure you lock it down before you go live ;).

0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
barnster123Author Commented:
I've followed this and still get the same 500 error. There must be some other underlying permissions issue.

http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/9b619620-4f88-488b-8243-e6bc7caf61ad.mspx?mfr=true
0
 
b_levittCommented:
what 500 error is that?
0
 
barnster123Author Commented:
Permission issue most probably.
0
 
b_levittCommented:
No, what is the actual message?  make sure "show friendly error messages" are disabled in your browser (tools --> internet settings --> advanced tab in your browser.
0
 
barnster123Author Commented:
There was no solution given but I figured out this issue myself. I need this coldes so I can ask another question.
0
 
b_levittCommented:
According to your objection you used my recommended solution of creating a copy of the user on the other computer:
"On 10/19/2009, the question was going to be accepted for the following reason:
 This was a permission issue, an identical suer is creted on teh second server."
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.