Solved

connect to Oracle 11g instance

Posted on 2009-05-08
21
2,476 Views
Last Modified: 2013-11-11
Experts,

        I need to connect to the database instance in Oracle 11g. I'm getting an error Failed to Connect. cant' establish a connection to the server at localhot.localadmin:1158

Here's the url:  https://localhost.localdomain:1158/em/

Thanks, MIssymadi
0
Comment
Question by:missymadi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 10
21 Comments
 
LVL 40

Expert Comment

by:omarfarid
ID: 24337061
check the ports and see if you have a firewall blocking your connection and that the remote system is running the listener.
0
 

Author Comment

by:missymadi
ID: 24337168
How do I check that in Linux? I
0
 
LVL 48

Expert Comment

by:schwertner
ID: 24357129
Try this
https://localhost:1158/em/

But before this check if the instance is registered by the Listener:

lsnrctl status
lsnrctl services
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 48

Expert Comment

by:schwertner
ID: 24357142
Also the OEM should be up

emctl start dbconsole
0
 

Author Comment

by:missymadi
ID: 24358598
I'm in as root and typed lsnrctl status, and got:

TNS:no listener
TNS:12560:TNS protocol adapter error
TNS-00511: No listener
Linux ERRor 111: Connection refused

Why is the connection refused?
0
 
LVL 48

Expert Comment

by:schwertner
ID: 24361496
Then start the Listener:

lsnrctl start
emctl start dbconsole

Possibly the Oracle instance is also not startted

% sqlplus /nolog
SQL>connect sys/password@your_instance as sysdba
SQL>startup
0
 

Author Comment

by:missymadi
ID: 24364747
I entered lsnrctl start (as root)
I got the error:
Error listening on (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1521)))
TNS-12555:TNS:permission denied
TNS-12560: TNS:protocol adaptor error
TNS-00525 Insufficient privelige for operation
Linux ERROR: Operation not permitted.

Listener failed to start

How do I fix this error?
Also, it seems that when I changed the HOSTNAME all the problems started. I changed the hostname back to localhost.localdomain and now I have these errors. I do need to change the hostname to mission-rh2 to bind to the IP address when this db goes into prduction. The files that I changed are: /etc/sysconfig network and /etc/hosts. I also made a change to the listener.ora file: I added listener.ora location=/u01/app/oracle/product/11.1.0/db_1/network/admin

Thanks!
0
 
LVL 48

Expert Comment

by:schwertner
ID: 24372517
Root can not start the Listener!
Listener should be started from 'oracle' user account.
If you have changed the hostname then go to LISTENER.ORA
file and change the HOST_NAME there appropriatelly.
After that start the Listener.
0
 

Author Comment

by:missymadi
ID: 24378666
I changed the listener file. The listener started, the orcl database mounted and is up. However I still cannot access the db through Oracle Enterprise Manager. The error is failed to connect using the url
https://mission-2:1158

0
 
LVL 48

Expert Comment

by:schwertner
ID: 24382309
https://mission-2:1158/em

But before this check if the instance is registered by the Listener:

lsnrctl services

If it is not mentioned do static registration of the instance:

Backup LISTENER.ORA file!!!!!!!

In ...\network\admin open listener.ora

see

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = D:\Ora10g)
      (PROGRAM = extproc)
    )
    (SID_DESC =
      (SID_NAME = test)
      (ORACLE_HOME = D:\Ora10g)
    )
  )

Add the entry
    (SID_DESC =
      (SID_NAME = test)
      (ORACLE_HOME = D:\Ora10g)
    )
with regard to the particular Oracle Home and SID Name.


In Oracle 11g you have to create from scratch in the listener.ora file the section

SID_LIST_LISTENER =
&..

mentioned above.

Restart the listener:
c:>lsnrctl stop
c:>lsnctl start
0
 

Author Comment

by:missymadi
ID: 24385690
Here is what my listener.ora looks like:
#
#
#
LISTENER =
   (DESCRIPTION LIST =
      (DESCRIPTION =
         (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
         (ADDRESS = (PROTOCOL =TCP)(HOST=missionrh2)(PORT= 1521))
)
)
     SID_LIST_LISTENER =
         (SID_LIST =
               (SID_DESC =
               (SID_NAME = PLSExtProc
               (ORACLE_HOME = /u01/app/oracle/product/11.1.0/db_1)
               (PROGRAM=extproc)
           )
            (SID_DESC=
            (SID_NAME=orcl
            (ORACLE_HOME=/u01/app/oracle/product/11.1.0/db_1)
       )

I go to the $ORACLE_HOME/bin directory and run lsnrctl stop and an error is returned bash: "lsnrctl:command not found
0
 
LVL 48

Expert Comment

by:schwertner
ID: 24385870
Seems you use an user that is not the Oracle user (DBA group)
and it has not rights to execute lsnrctl. I am sure it exists there
and you also can see it.

Clarify the name of the 'oracle' user - the same that has installed Oracle
After that give him rights over /u01 and subdirectories:

% chown oracle /u01 -R
0
 

Author Comment

by:missymadi
ID: 24386011
I am using the oracle account. I also entered SU to change to root to see if I could get to the listener service but could not.
What is the exact syntax to give oracle acct rights over the oracle home directory?
0
 

Author Comment

by:missymadi
ID: 24386358
I set my environment variables and found the listener.
Anyway - I ran lsnrctl stop and get the following error
Connecting to (DESCRIPTION..address...protocol ipc...key..extproc1))
TNS-12541 TNS no listener
TNS-12560 TNS protocol adapter error
tNS 00511 no listener
Connecting to desc..address..protocol=tcp...host missionrh2 port=1521

TNS 12541 - tns no listener
tns 12560 TNS protocol adapter error
tns 00511 no listener
linux error 111 connection refused.


why isnt this working?
0
 

Author Comment

by:missymadi
ID: 24386982
listener is now working, I guess I just needed to wait for the settings to take place. Anyway, I started the listener and it is working now. I entered emctl start dbconsole and it returns:
https://localhost.localdomain://1158/em/console/aboutApplication  - An instance of OEM 11g....already running.
However my host name is mission-2? I changed the hostname to mission-2. I still cannot connect to Oracle enterprise manager through Firefox
0
 
LVL 48

Expert Comment

by:schwertner
ID: 24387329
Good!

The next step is to try to recreate the repository (see snppet).

Before this try to use the IP of the host instead the name.
To recreate the configuration files and repository for Database Console, run: 
$ emca -config dbcontrol db -repos recreate
 
STARTED EMCA at Jul 24, 2006 10:08:20 PM
EM Configuration Assistant, Version 10.2.0.1.0 Production
Copyright (c) 2003, 2005, Oracle.  All rights reserved.
 
Enter the following information:
Database SID: TESTDB
Database Control is already configured for the database TESTDB
You have chosen to configure Database Control for managing the database TESTDB
This will remove the existing configuration and the default settings and perform a fresh configuration
Do you wish to continue? [yes(Y)/no(N)]: Y
Listener port number: 1521
Password for SYS user: change_on_install
Password for DBSNMP user: manager
Password for SYSMAN user: manager
Email address for notifications (optional):
Outgoing Mail (SMTP) server for notifications (optional):
-----------------------------------------------------------------
 
You have specified the following settings
 
Database ORACLE_HOME ................ /u01/app/oracle/product/10.2.0/db_1
 
Database hostname ................ linux3
Listener port number ................ 1521
Database SID ................ TESTDB
Email address for notifications ...............
Outgoing Mail (SMTP) server for notifications ...............
 
-----------------------------------------------------------------
Do you wish to continue? [yes(Y)/no(N)]: Y
Jul 24, 2006 10:08:50 PM oracle.sysman.emcp.EMConfig perform
INFO: This operation is being logged at /u01/app/oracle/product/10.2.0/db_1/cfgtoollogs/emca/TESTDB/emca_2006-07-24_10-08-20-PM.log.
Jul 24, 2006 10:08:53 PM oracle.sysman.emcp.util.DBControlUtil stopOMS
INFO: Stopping Database Control (this may take a while) ...
Jul 24, 2006 10:09:29 PM oracle.sysman.emcp.EMReposConfig dropRepository
INFO: Dropping the EM repository (this may take a while) ...
Jul 24, 2006 10:11:23 PM oracle.sysman.emcp.EMReposConfig invoke
INFO: Repository successfully dropped
Jul 24, 2006 10:11:23 PM oracle.sysman.emcp.EMReposConfig createRepository
INFO: Creating the EM repository (this may take a while) ...
Jul 24, 2006 10:15:09 PM oracle.sysman.emcp.EMReposConfig invoke
INFO: Repository successfully created
Jul 24, 2006 10:15:18 PM oracle.sysman.emcp.util.DBControlUtil startOMS
INFO: Starting Database Control (this may take a while) ...
Jul 24, 2006 10:17:21 PM oracle.sysman.emcp.EMDBPostConfig performConfiguration
INFO: Database Control started successfully
Jul 24, 2006 10:17:22 PM oracle.sysman.emcp.EMDBPostConfig performConfiguration
INFO: >>>>>>>>>>> The Database Control URL is http://linux3:1158/em <<<<<<<<<<<
Enterprise Manager configuration completed successfully
FINISHED EMCA at Jul 24, 2006 10:17:22 PM

Open in new window

0
 

Author Comment

by:missymadi
ID: 24387589
Things were going good until I got to an error:
SEVERE: Error starting Database Control
Could not complete the configuration. From the logs : WARNING: Error executing /u01/app/oracle/product/11.1.0/db_1/bin/emctl start dbconsole....Error starting db control ...at oracle.sysman.emcp.EMconfigAssistant.main(EMConfigAssistant.java:467)
0
 
LVL 48

Expert Comment

by:schwertner
ID: 24387930
Look here and repeat the steps.
0
 

Author Comment

by:missymadi
ID: 24389031
GREAT! I repeated the emca process and it finally finished! I connected to OEM! Thanks for your help.

One question, mission-rh is on port 5500. Where is the port number set? I thought it would be on 1158?

0
 
LVL 48

Accepted Solution

by:
schwertner earned 500 total points
ID: 24393543
Look in portlist file for actual ports.
Now it will be on 5500, but give a try or check in portlist file.
0
 
LVL 48

Expert Comment

by:schwertner
ID: 24401681
I will also so say GREAT!
Good luck!
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Zimbra on Amazon Linux help 7 108
SSL/TLS - openssl troubleshooting 3 59
Recover Lacie Edmini data. 11 63
Post Clonezilla image restore issue 6 62
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
When it comes to protecting Oracle Database servers and systems, there are a ton of myths out there. Here are the most common.
This video shows how to copy an entire tablespace from one database to another database using Transportable Tablespace functionality.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question