[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 573
  • Last Modified:

swapped switches in office, now DNS lookups are very slow

I recently swapped a switch with another switch in the office.  The #1 switch was loud... I wanted to get it in another location that is more enclosed while I get some fans ordered for it.  I did a swap between location #1 and #2.

Now my DNS lookups are very slow.  I have reset all three switches, upgraded the firmware to most recent versions... when I do a firmware backup to my laptop it is giving me 5k... this is coming from the switch directly to the laptop through a cat5 cable!

All I did was swap two switches in the office... what could be causing this?  I have flushed arp caches on our firewall and on the server.  I see no way to flush the arp cache on the switches themselves (nice huh?).

These are DLINK DGS1248t switches.  Thanks.
0
sduvall1
Asked:
sduvall1
1 Solution
 
nrpanchalCommented:
Can you verify whether the connection to DNS servers (or any other relevent) are working in FULL duplex or half duplex ? It might be possible that after the change, some connectivity has been negotiated in Half-duplex which is causing this poor performance.

HTH
nayan panchal
0
 
sduvall1Author Commented:
All ports are set to auto negotiate and they are all appearing as 100M Full or 1000M Full...
0
 
nrpanchalCommented:
Hmm, Can you check for any possible issues with changed firmware?

I am not sure whether DLINK switch supports SPAN, if yes may be you can capture DNS traffic to dig further. Whether DNS server is getting all the requests?

HTH
nayan panchal
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
alvesvaCommented:
If everything else failed, try disabling the NIC(s) on the DNS server for about a minute and re-enable it.

I hope it helps!
0
 
joebenz1980Commented:
try hardcoding your speed duplex settings on your switch and server.  i know with cisco, there are sometimes issues with autonegotiating.
0
 
sduvall1Author Commented:
I will try rebooting the server and hard coding the speed and duplex settings... thing is that auto worked before I swapped the switches and they are exactly the same... I had a DGS1248Tb in the lower level of our building... and I swapped it with a DGS1248Tb in the upper level of the building.  They might as well be the same switch.

I've never seen a switch behave this way.  I've plugged up numerous switches (personal to enterprise) and I've never seen anything occur like this.
0
 
sduvall1Author Commented:
I had 4 forwarding servers specified on my DNS server.  I decided to try connecting to them and doing DNS lookups... 2 of the 4 timed out when using them for lookups.  They were the two at the top of the forwarding list.  I removed them from the list and now the internet is fast again.

I have no idea why this worked faster when the DNS server was plugged into a different switch... but after swapping the switches this problem became apparent but it looks like the problem was on the DNS server... not the switch.
0
 
nrpanchalCommented:
glad to know that things are working fine now for you.

nayan :)
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now