swapped switches in office, now DNS lookups are very slow

Posted on 2009-05-08
Last Modified: 2012-05-06
I recently swapped a switch with another switch in the office.  The #1 switch was loud... I wanted to get it in another location that is more enclosed while I get some fans ordered for it.  I did a swap between location #1 and #2.

Now my DNS lookups are very slow.  I have reset all three switches, upgraded the firmware to most recent versions... when I do a firmware backup to my laptop it is giving me 5k... this is coming from the switch directly to the laptop through a cat5 cable!

All I did was swap two switches in the office... what could be causing this?  I have flushed arp caches on our firewall and on the server.  I see no way to flush the arp cache on the switches themselves (nice huh?).

These are DLINK DGS1248t switches.  Thanks.
Question by:sduvall1
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Expert Comment

ID: 24337292
Can you verify whether the connection to DNS servers (or any other relevent) are working in FULL duplex or half duplex ? It might be possible that after the change, some connectivity has been negotiated in Half-duplex which is causing this poor performance.

nayan panchal

Author Comment

ID: 24337381
All ports are set to auto negotiate and they are all appearing as 100M Full or 1000M Full...

Expert Comment

ID: 24337555
Hmm, Can you check for any possible issues with changed firmware?

I am not sure whether DLINK switch supports SPAN, if yes may be you can capture DNS traffic to dig further. Whether DNS server is getting all the requests?

nayan panchal
How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.


Expert Comment

ID: 24338099
If everything else failed, try disabling the NIC(s) on the DNS server for about a minute and re-enable it.

I hope it helps!

Expert Comment

ID: 24338612
try hardcoding your speed duplex settings on your switch and server.  i know with cisco, there are sometimes issues with autonegotiating.

Author Comment

ID: 24339793
I will try rebooting the server and hard coding the speed and duplex settings... thing is that auto worked before I swapped the switches and they are exactly the same... I had a DGS1248Tb in the lower level of our building... and I swapped it with a DGS1248Tb in the upper level of the building.  They might as well be the same switch.

I've never seen a switch behave this way.  I've plugged up numerous switches (personal to enterprise) and I've never seen anything occur like this.

Accepted Solution

sduvall1 earned 0 total points
ID: 24365335
I had 4 forwarding servers specified on my DNS server.  I decided to try connecting to them and doing DNS lookups... 2 of the 4 timed out when using them for lookups.  They were the two at the top of the forwarding list.  I removed them from the list and now the internet is fast again.

I have no idea why this worked faster when the DNS server was plugged into a different switch... but after swapping the switches this problem became apparent but it looks like the problem was on the DNS server... not the switch.

Expert Comment

ID: 24365403
glad to know that things are working fine now for you.

nayan :)

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Need help with VLAN issue 6 82
eigrp routing loop 5 93
Switch ports not working 8 95
NTP configuration on Cisco switch 3 39
The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
This video shows how to use Hyena, from SystemTools Software, to update 100 user accounts from an external text file. View in 1080p for best video quality.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question