• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 330
  • Last Modified:

Fixing permissions for SQL Jobs

Below is there error message I get when trying to run a SQL Job. I have an idea of what the problem is but can seem to find the palce to change the username and password.

I am trying to run a legacy DTS package in a scheduled job but the job fails due to an invalid password. I checked the server configuration Manager and Surface Area Configuration but the account in the error message below is not listed as the SQL Server Agent account.

I'm running SQL Server 2005 and I have my SQL Agent setup to run as a domain admin account instead of the default local service. Everything worked fine until this morning when the domain admin account password expired and I had to change it. I'd like to change the domain acount that is used by SQL server but I can find where to change the account and password.





Date            5/8/2009 10:36:58 AM
Log            Job History (Job Name)

Step ID            1
Server            TIC-BAAN
Job Name            Job name
Step Name            Execute DTS
Duration            00:00:00
Sql Severity            0
Sql Message ID            0
Operator Emailed            
Operator Net sent            
Operator Paged            
Retries Attempted            0

Message
Unable to start execution of step 1 (reason: Error authenticating proxy Domain\User, system error: Logon failure: unknown user name or bad password.).  The step failed.
0
ticgums
Asked:
ticgums
  • 3
1 Solution
 
ticgumsAuthor Commented:
Thanks for the suggestion, I tried changing the owner of the job but that didn't work. Still get the same error.

The links you included are for SQL 2000, I am running SQL 2005.
0
 
ticgumsAuthor Commented:
Will post a comment explaining why I said partially.
0
 
ticgumsAuthor Commented:
Changing the owner of the SQL Job was not what needed to be done but it made me rethink the job process and how the steps run. Each step of the job was set to "run as" a specific user (custom credential) So I changed the "run as" option for the first step and it worked. I then went in to the security credentials and update the custom credential that I created to use an AD service account that did not have an expiring password.

Thanks for getting me on the right track.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now