• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 388
  • Last Modified:

CSS z-index issue with Object tags

please go to this site http://www.imblog.info/css-fix/search.htm
there will be a top green bar navigation that stays at top. now move ur scrolls bars down and u will see that there is a white part of youtube code that shows at top of everything . i want to make it down than navigation ..

please help ..
0
hiddenpearls
Asked:
hiddenpearls
  • 5
  • 2
  • 2
  • +1
1 Solution
 
echase5Commented:
The youtube code does not show up at all in Safari.
0
 
hiddenpearlsAuthor Commented:
it is white space ...

imagine there is a youtube code.
0
 
echase5Commented:
Doesn't render incorrectly in safari, probably the IE z-index bug. Try adding "position: relative" to the stle of the offending object, and declare the z-index there.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
hiddenpearlsAuthor Commented:
yes , its not working in IE. try in FF please.
0
 
hiddenpearlsAuthor Commented:
can u grab all the files from the site and test it .. thanks .
i have putted z-index everywhere but nothing is working .
0
 
David S.Commented:
It looks like the wmode property was not set for it.

More information: http://forums.devshed.com/css-help-116/z-index-flash-file-getting-element-to-overlay-on-flash-505401.html
0
 
myderrickCommented:
Try setting the vmode to transparent or opaque (if transparent doesn't work)

Good luck

MD
0
 
hiddenpearlsAuthor Commented:
below is the code i m using ... please look at that . i have tried both transparent and opaque.
nothing is working .


      <div class="insertssml_right" style="z-index:-12345" ><script type="text/javascript">
AC_AX_RunContent( 'height','405','src','search_files/KbEMhU_dWJYhlenfs1border1.swf','type','application/x-shockwave-flash','allowscriptaccess','always','allowfullscreen','true','movie','http://www.youtube.com/v/KbEMhU_dWJY&hl=en&fs=1&border=1' ); //end AC code
</script>
<noscript style="z-index:-12345" ><object height="405" style="z-index:-12345" ><param name="movie" value="http://www.youtube.com/v/KbEMhU_dWJY&amp;hl=en&amp;fs=1&amp;border=1" style="z-index:-12345" >
  <param name="wmode" value="opaque">
<param name="allowFullScreen" value="true">
<param name="allowscriptaccess" value="always">
<embed src="search_files/KbEMhU_dWJYhlenfs1border1.swf" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" height="405" style="z-index:-12345" ></object></noscript>
</div>

Open in new window

0
 
David S.Commented:
Try setting it on the <embed> too.
      <div class="insertssml_right" style="z-index:-12345" ><script type="text/javascript">
AC_AX_RunContent( 'height','405','src','search_files/KbEMhU_dWJYhlenfs1border1.swf','type','application/x-shockwave-flash','allowscriptaccess','always','allowfullscreen','true','movie','http://www.youtube.com/v/KbEMhU_dWJY&hl=en&fs=1&border=1' ); //end AC code
</script>
<noscript style="z-index:-12345" ><object height="405" style="z-index:-12345" ><param name="movie" value="http://www.youtube.com/v/KbEMhU_dWJY&amp;hl=en&amp;fs=1&amp;border=1" style="z-index:-12345" >
  <param name="wmode" value="opaque">
<param name="allowFullScreen" value="true">
<param name="allowscriptaccess" value="always">
<embed src="search_files/KbEMhU_dWJYhlenfs1border1.swf" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" height="405" wmode="opaque" style="z-index:-12345" ></object></noscript>
</div>

Open in new window

0
 
hiddenpearlsAuthor Commented:
thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 5
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now