Maxtor One Touch III does not show up as a drive

Posted on 2009-05-08
Last Modified: 2012-05-06
I have a friend with a Maxtor One Touch II that he uses to back up his 3 desktops computer (all Dells). Recently the drive stopped becoming available on his Optiplex 620. The drive does show in the Device Manager and in properties displays as working. However in My Computer, Windows Explorer or even Disk Management it does not show up.

I have unistalled device in Device Manager and when plugged back in it reinstalls but is still not available.
Question by:gblakele
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Assisted Solution

antontolentino earned 40 total points
ID: 24339482
Try to look at the Disk Management console. If it is there try to asign letter on it.

Rightclcik My computer>>Manage>>Disk Management

How many USB device is connected simultaneously?

Author Comment

ID: 24339671
Drive was not in Disk Management. Could only see it in Device Manager.

Assisted Solution

Jozer99 earned 20 total points
ID: 24339807
Sounds like a partition problem.  I would backup the drive, reformat, and restore the files to it.  

The other possible problem could be a registry issue with the computer.  Every USB device gets "remembered" in the registry, but this memory can get messed up.  Delete the device entry in the registry, and the computer will have to "relearn" the drive, which may fix the issue.  
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!


Assisted Solution

antontolentino earned 40 total points
ID: 24340562
Try to use other PC with that drive and make sure you are logged in with admin rights.

LVL 92

Assisted Solution

nobus earned 20 total points
ID: 24342740

Assisted Solution

rop12770 earned 20 total points
ID: 24481433
Sounds like a partition problem. Get a program called Partition Doctor e try to repair the partition. It should solv that.

Author Comment

ID: 24788337
Drive works fine on 2 other systems. It is not a partition. It is a device issue
The following worked
1.Press [Windows]+[Break] to bring up the System Properties dialog box.
2.Select the Advanced tab and click the Environment Variables button.
3.Click the New button below the System Variables panel.
4.In the New System Variable dialog box, type devmgr_show_nonpresent_devices in the Variable Name text box and 1 in the Variable Value text box.
5.Click OK to return to the System Properties dialog box and then click OK again.
6.Select the Hardware tab and click the Device Manager button.
7.In Device Manager, go to View | Show Hidden Devices.
8.Expand the various branches in the device tree and look for the washed out icons, which indicate unused device drivers.
9.To remove an unused device driver, right-click the icon and select Uninstall.

Accepted Solution

gblakele earned 0 total points
ID: 24850523
Solved problem on my own

Author Comment

ID: 24850577

Author Comment

ID: 24850581

Featured Post

WordPress Tutorial 2: Terminology

An important part of learning any new piece of software is understanding the terminology it uses. Thankfully WordPress uses fairly simple names for everything that make it easy to start using the software.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
A look at what happened in the Verizon cloud breach.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
Suggested Courses

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question