• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5434
  • Last Modified:

Exchange 2007 Document Level Backup with CA ARC SERVE r12.0 (Build 5454)

Hi to all.
I´m trying to make a backup at document level, but I can´t connect to the mailboxes.
I can see the First&Second Storage Group, but when I click in those to see each mailboxes a login screen appears, and there isn´t users with login succesfull.
Any clues?

Tks to all.
1 Solution
For my BE 12.5 to do that I had to install the ExchangeMapicdo update from MS.  I found it throught the technet website.  www.microsoft.com/technet.  Then went to downloads, the Exchange servers. Choose the Microsoft Exchange Server MAPI client and Collaboration Data Objects 1.2.1 link and downloaded the update
at_userAuthor Commented:
Yes, before install the MAPI I don´t saw the Storages Groups, but now I´m stucked here.
after installing the Latest MAPI CDO grant full Exchange permissions to the account in the exchange system manager ( when you select the mail box on the right pannel you have granmt full permissions) which we are using in security credentials for the document level and then make sure that the mail box is activated

also make sure that the account which we are using  for document level in the backup manager has the following local security policies

1) Log On Locally
2) Log On as A service
3) Act as a part of OS

and the same account should be added in local admin group
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.


Are you running Exch 2007 on Windows 2008 ? If so they are supported only with r12 SP1 Build 5582.

Document Level backups require certain permissions to be set for the account. Please refer to the following document and make sure you meet all the requirements..


check the 2nd section - for document level backups in: https://support.ca.com/irj/portal/anonymous/redirArticles?reqPage=search&searchID=TEC436398

particularly point number 4.
This problem can happen because of one of the following:

1. Use the Built in "Administrator" Account while Browsing Document Level instead of using any other Account with similar privileges.

2. Document Level Agent Browsing and Backup using Exchange 2007 SP1 on a Windows 2008 SP1 server is only supported with ARCserve r12.0 SP1 and higher. It is not supported with ARCserve r12.0 with no service pack.

3. The Messaging API (MAPI) Client and Collaboration Data Objects (CDO) must be at a minimum level of Version 1.2.1 (8022.0). Earlier versions of the MAPI CDO are not supported.

4. Verify that the user account designated as the Document Level backup accounts meets all of the prerequisites described in Following Technical document:

5. There are two methods for resolving this problem. Method 1 involves editing the hosts file for windows so that the lines in the host file are in the exact order shown. Method 2 involves disabling IPv6. Either Method 1 or Method 2 must be used.

Method 1

Open the hosts file located at %SystemRoot%\system32\drivers\etc\ by using an editor such as Notepad

Search for the line that contains the term "::1" and comment out the line by putting a number sign (#) at the beginning

Add the following two lines to provide the TCP/IPv4 address, hostname, and FQDN name for the Exchange 2007 server
<TCP/IPv4 address> <host name of the computer>
<TCP/IPv4 address> <FQDN of the computer>
Click Save, and then close the file
Example of what the host file should look like after making above changes: localhost
#::1 localhost EX2007Server EX2007Server.ca.com

Method 2

In the Network Connections folder, obtain properties on all of your connections and adapters and clear the check box next to the Internet Protocol version 6 (TCP/IPv6) component in the list under This connection uses the following items.

This method disables IPv6 on your LAN interfaces and connections, but does not disable IPv6 on tunnel interfaces or the IPv6 loopback interface.

Add the following registry value (DWORD 32 Bit) set to 0xFFFFFFFF:
This method disables IPv6 on all your LAN interfaces, connections, and tunnel interfaces but does not disable the IPv6 loopback interface.

You must restart the computer for this registry value to take effect.

6. You may use any Domain Administrator equivalent with full Domain Administrator privileges but will require the following workaround. The workaround for this option is to turn off User Access Control on the Exchange server if has not already been done by following the steps below.

Click Start, and then click Control Panel .
In Control Panel, click User Accounts.
In the User Accounts window, click User Accounts.
In the User Accounts tasks window, click Turn User Account Control on or off.
If UAC is currently configured in Admin Approval Mode, the User Account Control message appears. Click Continue.
Clear the Use User Account Control (UAC) to help protect your computer check box, and then click OK.
Click Restart Now to apply the change right away, or click Restart Later and close the User Accounts tasks window.

After trying the above steps, if it still doesnt work, enable debug on Document Level Agent:
Open Backup Agent Admin-> Exchange Agent-> Configuration-> Document Level-> Log Level Detail, Set it to 5.
Try expanding the Storage groups from backup source, attach the exsispa*.trc which would be saved in the CA Arcserve Agent for Microsoft Exchange, Document Level, Log Folder.


Forgot to attach the links:

Title:  Microsoft Exchange Server - Document Level browse and backup does not work with MS Exchange Server 2007 installed on Windows 2008

Title:  CA ARCserve Backup Account Permissions required for Exchange Database Level and Document Level Backup and Restore

Title:  Unable to expand Storage Groups under Microsoft Exchange Server - Document Level database object

at_userAuthor Commented:
Hi to all.
The solution was a mix of all the answers, but the most accuratte answer was by Malikstays.
Tks for all.
at_userAuthor Commented:
Hi to all.
The solution was a mix of all the answers, but the most accuratte answer was by Malikstays.
Tks for all.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now