Exchange 2003 database is corrupt. Cannot backup.

Hello.

My current Exchange 2003 database is corrupt and backup exec and ntbackup will not successfully backup the database. When I went to perform a restore, Backup Exec stated that the backups were corrupt. The last good backup was over a month ago.

Event viewer reports Event ID 478.
The expected checksum was 3201341912 (0x00000000bed099d8) and the actual checksum was 2309737967 (0x0000000089abcdef).  The read operation will fail with error -613 (0xfffffd9b).  If this condition persists then please restore the database from a previous backup.

I am running Exchange 2003 Standard. Is there another alternative to restoring the month old database and then trying to import in the new data? I have never ran into this issue and would appreciate any assistance.

Can I perhaps run exmerge on the "LIVE" database and somehow import all of the database into a new database and switch it out with the current corrupt database?

xtmsportsAsked:
Who is Participating?
 
gauravbhandariConnect With a Mentor Commented:
Hi,
One more thing that can be done in this case.

- Create a Recovery Group from ESM & add the database into it.
- Dismount the production mailbox store & move the files in the Recovery Storage Group folder (check the loaction while creating).
- Rename priv1.edb & priv1.stm with Mailbox Database (servername).edb & .stm respectively.
- Mount the production mailbox store & the Recovery Mailbox Store.
- Right click disconnected mailboxes under Recovery Storage Group & using exchange tasks, we can merge the emails back to current mailboxes.
- This task would take some time but will do the same thing as repair.

You can also refer to the following articles:

http://support.microsoft.com/kb/824126

http://www.msexchange.org/tutorials/Recovering-Mailboxes-Exchange2003-SP1.html

Hope this helps :-)
0
 
Britt ThompsonConnect With a Mentor Sr. Systems EngineerCommented:
This article will tell you how to run the ESEUTILs and ISINITEG to repair your database. If that doesn't work we'll get into other options.

http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html
0
 
jesusrulesmeConnect With a Mentor Commented:
I would recommend using the eseutil /g to check the integrity and isinteg -fix -alltests to correct some errors, then run eseutil /d to defragment the database.  A good tutorial on this can be found here:

http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Britt ThompsonSr. Systems EngineerCommented:
Actually, ISINTEG FIX is probably what you'll need to do.
0
 
jesusrulesmeCommented:
Wow, renazonse...looks like we're on the same page. :-)
0
 
xtmsportsAuthor Commented:
Thanks renazonse and jesusrulesme.

I will try these tonight and update you.
0
 
Britt ThompsonSr. Systems EngineerCommented:
Yeah...don't you hate that. For once I typed faster than someone else.
0
 
xtmsportsAuthor Commented:
Just another piece of information since you both recommended using the eseutil.

I performed an offline defrag about a month ago and it failed with the following error:

checksum error in SLV file during backup

Operation terminated with error -613  
 
(JET_errSLVReadVerifyFailure, Checksum error in SLV file during backup)
0
 
Britt ThompsonSr. Systems EngineerCommented:
Yeah...same thing. Need to run the repair.
0
 
gauravbhandariCommented:
Additional Information: RSG can only be used for Mailbox Store & not for Public Folder Store.
0
 
xtmsportsAuthor Commented:
I talked to MIcrosoft and the recommended that I unmount the database and then moved/renamed the folder containing the transaction logs. Then mount the database and it will recreate the transaction log folder. Then run NTbackukp; which I did do and not luck.

Second suggestion was to run isinteg -s (server) -fix -test alltests

The first time I ran it, it had 53 fixes, so I ran it a second until I received ALL zeroes. Then I ran NTbackup and still no luck.

Now Microsoft is saying its probably hardware related to my hard disk. It sounds like Microsoft is blowing smoke now.

Any other suggestions would be appreciated.

Thanks.
0
 
xtmsportsAuthor Commented:
Hi guy,

Microsoft was blowing smoke and I called them on it regarding a hardware issue. I ran a backup of the public store with no issues on the same hard drive. So that eliminated their guess of a hardware issue.

I ended up doing a database repair with the eseutil /p "D:\Exchsrvr\Mailbox Store (SERVER).edb"

Then ran a defrag and isinteg.

Thanks for all your help!


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.