Solved

Windows Media Player does not detect Pocket Tunes / Treo

Posted on 2009-05-08
9
522 Views
Last Modified: 2013-11-12
I've been syncing Pocket Tunes and Windows Media Player for years (literally!) with no problems, but now I have a problem.

Last week, I had to do some work for a vendor that entailed installing their software on my computer. That did screw up a bunch of things in my normal working environment, most of which I have fixed by uninstalling their software and everything it brought in. However, I may have uninstalled too much.

Note that the vendor also ran cc cleaner on my pc - something I would normally not let anyone do, but then - it's too late now!

What's happening now is that when I open WMP (vsn 11) on my pc and drag something into the sync pane, then connect my Treo 700p with PocketTunes vsn 4.0.5 open, WMP does not detect the device.

If I go into device manager, there is a yellow exclamation mark on the Palm device under Portable Devices.

I read this article: http://www.microsoft.com/windows/windowsmedia/player/11/readme.aspx
specifically the section "Device not recognized after installing Windows Media Player 11" and I did what it said: uninstall the item in device manager and then let it reinstall with PnP. But the install fails with this error:

MTP Device: The specified service does not exist as an installed device.

This WAS all working fine in WMP 11 before the vendor's software installation and recovery.

Note that I had also had a problem (after the vendor software fiasco) where Hotsync would not sync with Outlook any longer. I did a "detect and repair" on Outlook and that solved the problem.

Also note that one of the programs I uninstalled while trying to cleanup was Silverlight - I didn't know what it was at the time. In my searches through forums, I see a tiein between WMP and Silverlight so I don't know if that is the problem or not?

So I thought that installing and reinstalling PocketTunes and WMP would do the trick. I uninstalled PocketTunes and reinstalled it. Then I also tried to uninstall WMP and reinstall it via Control Panel, Add/Remove programs > Windows Setup. I'm not sure that that really did uninstall/reinstall.

I still have the same problem.

Does anyone know what "MTP Device: The specified service does not exist as an installed device." this means? I've Googled it but haven't found the solution. How do I get "MTP Device" to be an installed device? OR, the real question: how do I get WMP 11 to again detect PocketTunes on my Treo?
0
Comment
Question by:alicia1234
  • 7
  • 2
9 Comments
 

Expert Comment

by:quagmire0
ID: 24340637
I've had similar issues with devices not being detected.  In almost every case it is the driver.  Try reinstalling the software for the device.  If you remove the Treo software and reinstall and still have the issue, try using Revo Uninstaller to remove the Treo software -and remove any traces of it.  Then reboot and reinstall.  
0
 

Author Comment

by:alicia1234
ID: 24340685
Thanks. But at this point I don't know what the "software for the device" is!! What is "the Treo Software"?
0
 

Author Comment

by:alicia1234
ID: 24340690
I have already reinstalled "Palm Desktop" and "Hotsync".
0
 

Author Comment

by:alicia1234
ID: 24340743
Note that HotSync works fine.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:alicia1234
ID: 24340898
I'm not sure if it's even supposed to be an "MTP" Device? In new hardware wizard, I tried to have it install as "Palm OS Handheld Devices" but when I click "Next" nothing happens.

If I select "Portable Devices" then the only choice is MTP Device.

If I try "USB controllers" (a suggestion I read somewhere).

Found New Hardware wizard is saying it found "Pocket Tunes" - and then says it will help install software for MTP Device.

This is with Treo connected via USB and Pocke Tunes running on it.

In Device Manager, "Pocket Tunes" is listed under "Portable Devices" with a yellow exclamation mark.
0
 

Author Comment

by:alicia1234
ID: 24355297
I'm still struggling with this. Can anyone help me?

I have:
Uninstalled and reinstalled WMP 11
Uninstalled and reinstalled Pocket Tunes 4.0.5 - numerous times
Tried numerous suggestions I found on the web for the specific error (see my first post) - nothing has worked.



0
 

Expert Comment

by:quagmire0
ID: 24355997
Try going into Device Manager and right clicking on the device with the yellow exclamation mark.  Click on Properties > Driver > Driver Details.  Take note of the driver(s), unplug the device and then rename the driver files that you saw to something else.  Then try reinstalling Pocket Tunes and connecting the device.
0
 

Author Comment

by:alicia1234
ID: 24356283
guagmire0: Already tried all that - several times.

0
 

Accepted Solution

by:
alicia1234 earned 0 total points
ID: 24356333
I solved the problem. The trick was to uninstall and reinstall WMP 11. I thought I had done that through Add Remove Programs - Windows Setup by unchecking the box for WMP, then going in again and checking it. But that did not do it.

What I hadn't realized is that WMP 11 actuall shows up in the Add/Remove Programs list. So I removed "Windows Media Player 11" and "Windows Media Format Runtime 11". This rolled WMP back to vsn 10.

With vsn 10, WMP detected the Treo.

I then updated to WMP 11 (as I said, WMP 11 always worked fine before vendor's software had been installed). I updated through the WMP 10 Help menu - check for updates.

Then I opened WMP 11; connected my Treo to the USB port and opened Pocket Tunes on it. "Found New Hardware - MTP Device" popped up in the status bar. Stayed there a long time (a couple of minutes) with no real "install" windows coming up - but eventually I got a message that the device had been installed. I was told to reboot.  I did, and now it's all working correctly.

So: Obviously what happened is the MTP driver stuff got screwed up. Rolling WMP 11 back to vsn 10 and then upgrading to 11 again solved the problem.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
This is Part 3 in a 3-part series on Experts Exchange to discuss error handling in VBA code written for Excel. Part 1 of this series discussed basic error handling code using VBA. http://www.experts-exchange.com/videos/1478/Excel-Error-Handlin…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now