We help IT Professionals succeed at work.

Sonicwall VPN Global client reports connected but cannot get IP address from remote network.

afflik1923
afflik1923 asked
on
13,990 Views
Last Modified: 2012-05-06
A user can connect to the office VPN (have sonicwall TZ170) but cannot get an IP address. (therefore if you ping any IP address on the remote network it fails)

the log shows Failed to receive an incoming ISAKMP packet. The length is incorrect.

All other users can connect to the office fine as can I with this particular users credentials.

This problem user uses the Global VPN client to connect to the office. This reports Connected as normal and seems fine. However the user does not seem to get an IP address from the remote network.
when I check the SonicWall VPN adaptor under the Windows XP Network connecions I noticed it is disabled. If I try enable it.
Enabling& and then soon after Connection Failed.

I check the Sonicwall log and it repeatedly has this error.
Failed to receive an incoming ISAKMP packet. The length is incorrect.

Now I have previously had issued with VPN and changing the MTU size resolved it. This users current MTU is 1462. I think before I changed it to 1500 and this fixed it. I dont want to change the MTU size now as Im worried this will kick the user out from his broadband connection and he wont be able to reconnect to his router as he does not have an Ethernet cable. I do not want to bring down his internet over the weekend as then I would have made things worse.

I also note the user is on an unencrypted wireless connection and even his router has the default password set. I dont think this could be anything to do with it but thought I would mention it.

Any ideas?
Comment
Watch Question

This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Think we have focused down the problem to the users router. Worked fine in other places (although only quick tests) and when he uses an ehternet cable at home all seems fine (again not long tests yet)
Was wondering if it could be related to his thinkpad at all and the various wireless profile settings (I notice they have VPN settings). Most users do not use thinkpads.

Also changed the MTU to 1500.

Do note sometimes the wireless does work at home even before the changes.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Never got to the true bottom of this but I user has not complained since changing the MTU to 1500 and setting up a new secure wireelss profile.
So assume it was local router / wireless related.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.