• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3371
  • Last Modified:

Mac client on Windows Server 2008 domain


I've been looking around the forum and havn't been able to find a solution to my problem.

Once i've hooked up my Mac client to my Win domain in the "Finder/Go/Network" no machine names appear so i'm not able to view my Win shares. Is there any way to view the clients here by default?

The only way I can actually access a share is by manually adding the Win client with the "Finder/Go/Connect to Server" option. I'm able to map the client using "SMB://IP_ADDRESS" and "SMB://MACHINE_NAME" so I suppose DNS is working fine with the Mac. When i'm prompted for my credentials my Win admin account passes OK and i'm able to view the desired client.  The problem with using the Connect to Server option is that everytime I log out of my Mac the next time a sign in I have to remap the Win client through the "Finder/Go/Connect to Server" option

Any ideas on how to resolve this issue?

Here are some details that you might find in handy.

Enviorment details:

Mac OS X 10.5.6
Windows Server 2008

AD Binging Status:

Bining to AD is OK.
The Mac client assigned machine name appears in the proper OU once binded.

Login details:

I'm signed in with my regular domain user in my Mac client using domain\user in the Mac log in startup prompt. So I assume my credential have been delegated properly in order to be able to access my network shares.

GPO Modifications:

Domain Controller Policy
Microsoft network client: Digitally sign communications (always) set to disabled
Microsoft network server: Digitally sign communications (always) set to disabled

Thanks for your time and help!
  • 2
1 Solution
You can try setting your favorite servers by pressing the plus button next to the server address (where you input SMB://MACHINE_NAME) to add it to a list of favorite servers. This may speed up the process.
Are you trying to solve this issue just for you or for a number of people on your network?
If it's just for you, you could try mount the network shares that you want to use and make sure they appear on the desktop. In system preferences go to accounts, select your user profile and then log in items, drag the mounted shares into that box and they should mount with the same credentials each time you log in.

Not certain if thiis works with logging in via AD but it's worth a try.
malkaj01Author Commented:
Graham thank you very much for your input. You've been very helpful.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now