Solved

Password in cisco router not svae?

Posted on 2009-05-10
10
934 Views
Last Modified: 2012-06-27
I have cisco router 2800 my  "#show startup-config" or "#show run" in below of my question but the problem when I reload the router I can access without any password to enable mode how I can secure the router
i need simple security with user name cisco and password is 1234
 
DMAM10-DMAM10-IP127#show startup-config 

Using 923 out of 196600 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname DMAM10-DMAM10-IP127

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

!         

username cisco privilege 15 secret 5 $1$QIrc$wNeC.aDI8DTvS4j8B.tO1

archive   

 log config

  hidekeys

!         

!         

!         

!         

!         

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.208

 encapsulation dot1Q 208

 ip address 172.31.106.206 255.255.255.252

!

interface FastEthernet0/1

 ip address 172.16.5.1 255.255.0.0

 duplex auto

 speed auto

!

router bgp 65360

 no synchronization

 bgp log-neighbor-changes

 neighbor 172.31.106.205 remote-as 65000

 no auto-summary

!

ip forward-protocol nd

!

!

no ip http server

!

!

!         

control-plane

!         

!         

line con 0

line aux 0

line vty 0 4

 login    

!         

scheduler allocate 20000 1000

end

Open in new window

0
Comment
Question by:AymanDasa
  • 5
  • 4
10 Comments
 
LVL 1

Expert Comment

by:totzi
ID: 24347137
How do you connect to your router? With a console cable or via ethernet?

If you come over the network, you have to configure the vty lines probably:

ena

conf t

line vty 0 4

login local

end

wr

Open in new window

0
 
LVL 1

Expert Comment

by:totzi
ID: 24347164
For console:
ena

conf t
 

line con 0

login local
 

line aux 0

login local
 

end

wr

Open in new window

0
 

Author Comment

by:AymanDasa
ID: 24347168
the new conf. is in below but its the same i can access to router without any password
--------------------------------------------------------------------------------
Cisco 2801 (revision 7.0) with 115712K/15360K bytes of memory.
Processor board ID FCZ1313135Z
2 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Press RETURN to get started!

DMAM10-DMAM10-IP127>enable
DMAM10-DMAM10-IP127#
-----------------------------------------------------------
!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

 login local

!

scheduler allocate 20000 1000

end       

Open in new window

0
 
LVL 1

Expert Comment

by:totzi
ID: 24347180
How are you connected with your router?
Please try the second config
0
 
LVL 1

Expert Comment

by:totzi
ID: 24347199
You can find it out with:
show users

Open in new window

0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:AymanDasa
ID: 24347245
I access throw serial-to-rj45-cable
serial-to-rj45-cable.jpg
0
 

Author Comment

by:AymanDasa
ID: 24347255
Dear totzi
DMAM10-DMAM10-IP127#show users 

    Line       User       Host(s)              Idle       Location

*  0 con 0                idle                 00:00:00   
 

  Interface    User               Mode         Idle     Peer Address

Open in new window

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 24347561
If you're trying to use the local account to authenticate, then you don't have the console and vty lines set to local authentication.

line con 0

 login local

line vty 0 4

 login local

Open in new window

0
 

Author Comment

by:AymanDasa
ID: 24347568
its work mr donjohnston

THANKS FOR THAT
0
 
LVL 1

Expert Comment

by:totzi
ID: 24347722
I said this already...
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now