Solved

Password in cisco router not svae?

Posted on 2009-05-10
10
939 Views
Last Modified: 2012-06-27
I have cisco router 2800 my  "#show startup-config" or "#show run" in below of my question but the problem when I reload the router I can access without any password to enable mode how I can secure the router
i need simple security with user name cisco and password is 1234
 
DMAM10-DMAM10-IP127#show startup-config 
Using 923 out of 196600 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DMAM10-DMAM10-IP127
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!         
username cisco privilege 15 secret 5 $1$QIrc$wNeC.aDI8DTvS4j8B.tO1
archive   
 log config
  hidekeys
!         
!         
!         
!         
!         
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.208
 encapsulation dot1Q 208
 ip address 172.31.106.206 255.255.255.252
!
interface FastEthernet0/1
 ip address 172.16.5.1 255.255.0.0
 duplex auto
 speed auto
!
router bgp 65360
 no synchronization
 bgp log-neighbor-changes
 neighbor 172.31.106.205 remote-as 65000
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
!
!
!         
control-plane
!         
!         
line con 0
line aux 0
line vty 0 4
 login    
!         
scheduler allocate 20000 1000
end

Open in new window

0
Comment
Question by:AymanDasa
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 1

Expert Comment

by:totzi
ID: 24347137
How do you connect to your router? With a console cable or via ethernet?

If you come over the network, you have to configure the vty lines probably:

ena
conf t
line vty 0 4
login local
end
wr

Open in new window

0
 
LVL 1

Expert Comment

by:totzi
ID: 24347164
For console:
ena
conf t
 
line con 0
login local
 
line aux 0
login local
 
end
wr

Open in new window

0
 

Author Comment

by:AymanDasa
ID: 24347168
the new conf. is in below but its the same i can access to router without any password
--------------------------------------------------------------------------------
Cisco 2801 (revision 7.0) with 115712K/15360K bytes of memory.
Processor board ID FCZ1313135Z
2 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Press RETURN to get started!

DMAM10-DMAM10-IP127>enable
DMAM10-DMAM10-IP127#
-----------------------------------------------------------
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login local
!
scheduler allocate 20000 1000
end       

Open in new window

0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 
LVL 1

Expert Comment

by:totzi
ID: 24347180
How are you connected with your router?
Please try the second config
0
 
LVL 1

Expert Comment

by:totzi
ID: 24347199
You can find it out with:
show users

Open in new window

0
 

Author Comment

by:AymanDasa
ID: 24347245
I access throw serial-to-rj45-cable
serial-to-rj45-cable.jpg
0
 

Author Comment

by:AymanDasa
ID: 24347255
Dear totzi
DMAM10-DMAM10-IP127#show users 
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00   
 
  Interface    User               Mode         Idle     Peer Address

Open in new window

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 24347561
If you're trying to use the local account to authenticate, then you don't have the console and vty lines set to local authentication.

line con 0
 login local
line vty 0 4
 login local

Open in new window

0
 

Author Comment

by:AymanDasa
ID: 24347568
its work mr donjohnston

THANKS FOR THAT
0
 
LVL 1

Expert Comment

by:totzi
ID: 24347722
I said this already...
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Is this QoS Correct on this  CISCO 3825 Router 1 125
Routing between two networks? 10 88
Radius Debug Error 16 112
Cisco Edge Routers for BGP 6 91
This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question