Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Centos Bind DNS Problem

Avatar of phil8258
phil8258Flag for United Kingdom of Great Britain and Northern Ireland asked on
DNSLinux Distributions
12 Comments1 Solution2253 ViewsLast Modified:
I'm having trouble setting up the Bind DNS server on a Centos 5 machine (Bind 9).
I've so far followed a guide in "O'Reilly: DNS & BIND 4th ed", and done a bit of web trawling. What i've go looks ok to me, but the bottom line is that it does not work!

Bind installed with "yum install bind" - all went in ok.
The router forwards UDP port 53 to the server.
I've put what I think is correct into /etc/named.conf and /var/named/db.domainname.org.uk.
db.cache is also in that folder.

where domainname.org.uk is the domain that i'm trying to set up.

I've copied and pasted (and replaced the actual name with domainname) these 2 files below.

I'd much appreciate some expert advice!
Thanks in advance,
Phil.


Also, if it helps, i've tried nslookup from the server itself I get this:
nslookup domainame.org.uk returns:
Server:       127.0.0.1
Address:     127.0.0.1#53

and nslookup www.domainname.org.uk returns:
Server:       127.0.0.1
Address:     127.0.0.1#53

Name:     www.domainname.org.uk
Address: 181.186.156.104
Name:     www.domainame.org.uk
Address:   192.168.2.200

From any other machine either on the local network, or remote, nslookup fails.
named.conf as follows:
----------------------------
options {
	directory "/var/named";
	//Place additional options here
};
 
zone "domainname.org.uk" in {
	type master;
	file "db.domainname.org.uk.";
};
 
zone "." in {
	type hint;
	file "db.cache";
};
 
-------------------------------------------
db.domainname.org.uk. as follows:
-------------------------------------------
$TTL 3h
domainame.org.uk. IN SOA ns1.domainname.org.uk. root.domainname.org.uk. (
	1	; Serial
	3h	; Refresh after 3 hours
	1h	; Retry after 1 hour
	1w	; Expire after 1 week
	1h )	; Negative caching TTL of 1 day	 
 
 
;
; Name Servers
;
domainame.org.uk.	IN NS	ns1.domainame.org.uk.
domainame.org.uk	IN NS	ns2.domainame.org.uk.
 
;
; Host Addresses
;
localhost.domainame.org.uk.	IN A	127.0.0.1
www.domainame.org.uk.	IN A	181.186.156.104
www.domainame.org.uk.	IN A	192.168.2.200
;
; Aliases
;
phil.domainname.org.uk.	IN CNAME domainname.org.uk.
ASKER CERTIFIED SOLUTION
Avatar of jar3817
jar3817

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 12 Comments.
See Answers