Solved

Netout Ftp issues

Posted on 2009-05-10
7
920 Views
Last Modified: 2013-12-09
I have a very strange issue here. We recently upgraded our Linux server (Hardware and OS) and moved from proftp to vsftp. prior to the upgrade ms ftp had no issues connecting and could send large files from a remote server. Now when using ms ftp from any PC on the remote network with file over a half a meg we get a "NetOut: Connection reset by peer" error. Here is where it begins to get strange using core ftp I can put files of any size on the new box. Now it is getting even stranger. I can us msftp from any machine at home and put large files on the new box and I can ftp with ms ftp any file to my home server (Windows 2000, IIS5). Naturally I thought it was my firewall at the office (Linksys RV016) not liking the new server but I cannot for the life of me figure out where it could be going wrong. I have adjust the MTU from Auto to manual set at 1492 and 1500. I am at a loss and need to get this thing up and running as I have several batch files that put report data on the Linux box nightly.

Any insight would be great.

Thanks
Dan
0
Comment
Question by:panhead802
  • 3
  • 2
7 Comments
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 24352569
Have you had a look at http://www.dslreports.com/faq/6264
0
 

Author Comment

by:panhead802
ID: 24353400
The firewall in front of my ftp server does not accept icmp requests. So I cannot pint it to test like this.

Not so sure why changing servers would have this affect.

Dan
0
 
LVL 2

Expert Comment

by:jccs0519
ID: 24359755
FTP uses 2 tcp ports 20 & 21, sometimes it's pretty hard to troubleshoot especially w/ firewall involved.  Your new linux server may have its firewall enabled, w/ 2 tcp ports back and forth maybe a problem.  Sometimes passive FTP will work but sometimes it won't.  When you refer to msftp, you're talking about Windows Explorer FTP feature, right?  You can go to Internet Explorer options and change to Passive FTP and see if that works.

Personally, I recommend using WinSCP (it's free).  It uses ssh port (22) and it encrypts the data, so it's safer to transfer and you don't have to worry about the TCP 20/21 port issue.  All you have to do is have your firewall allow 22 open for ssh/scp for your server.  Then on your PC install WinSCP, then you can transfer files and shouldn't have problem.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:panhead802
ID: 24360365
By msftp I mean command line ftp, most of the ftp work is done through batch files so I need something I can call from the command line. Not so sure it can be a firewall port issue as I can send small files all day long but as soon as I get over 1mg it transfers for a while the I get the Netout error.

I can also transfer files from my home server to the new linux box no issues and I can transfer large files from my server at the office to my home server. (Home Server W2K)

I am at a loss.

Thansk
0
 
LVL 2

Accepted Solution

by:
jccs0519 earned 500 total points
ID: 24361631
Hmm, that does seems kinda weird.

I just re-read your question in detail.  So based on that, you used another FTP software "CoreFTP" and it works fine?  That sounds to me, the ms ftp software is not compatible w/ the vsftp on linux?

As a wild shot, try disable Linux firewall see if that helps.  If not, something not compatible w/ ms ftp w/ vsftp.  Try another command ftp program on Windows, maybe ncftp window client will work for you?

http://www.ncftp.com/download/

Although it's weird that ms ftp work from your home.  You may just have to tried several things different and try to troubleshoot one step at a time.
0
 

Author Comment

by:panhead802
ID: 24363463
Thanks for the input, I am going to look at ncftp and will let know how we make out.

Do you think I should set it up to transfer in Passive mode?

Thanks
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Access License Server from 2 locations 4 81
Ubuntu vs. Debian 4 106
SQL Query - Issue with Top Statement 5 46
Help With Shell Script Centos 6 6 54
This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
Outsource Your Fax Infrastructure to the Cloud (And come out looking like an IT Hero!) Relative to the many demands on today’s IT teams, spending capital, time and resources to maintain physical fax servers and infrastructure is not a high priority.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

832 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question