Citrix 4.5 access database problem

I have just upgraded my citrix server from version 4.0 to 4.5. The upgrade seemed to complete successfully however when I run discovery I get the following message:

This user account is not an administrator of this farm, or there was a problem contacting the data store. Check that the data store server for the Citrix Presentation Server farm is online, and verify that your account is configured and enabled as an administrator on the farm.

It seems that I cannot now connect to the access datastore.

When I go to a command prompt and do a dsmaint config to point to the database I get a "failed to connect to the datastore" message.

Something has clearly happened to the datastore but i don't know how to correct the issue.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Daniel BorgerSenior Citrix Engineer- CCEECommented:
Your local access datastore is in the program files\citrix\Independent Management Architecture. back these files up before trying too many things. The MF20.dsn should have the information about your datastore and the account used.
There is a chance that it is just your local host cache. If you have not tried recreate the local host cache.
net stop imaservice
dsmaint config recreatelhc
net start imaservice

verify that all citrix services are started.
Reconfigure and rerun the discovery.
use the DScheck command to verify your datastore

since it's an access database make sure you are using the correct user account. there is a utility called slim jim that will allow you to overwrite your administrator password for the datastore. typically you would need this if the server was taken out of the domain and the local administrator was not an Citrix admin.
dwm1Author Commented:
I recreated the local host cache but that did not alter the problem.

I have verified that all citrix services are started and I have re-run Discovery but with any improvement.

The DSCHECK tells me that it can't read package info from the data store.

I downloaded and ran Slim Jim but if I then run DSMAINT CONFIG I still get a "failed to connect to the data store" message.
dwm1Author Commented:
I think I spoke too soon, because after repeated attempts to run discovery after the steps above, it did eventually run successfully.
Thanks for your help

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dwm1Author Commented:
Thanks for your prompt help
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.