Windows 2008 time sync off!!

I have W32time enabled to sync to time.microsoft.com and the date/time settings set to PST, but the time is showing +8 ahead of PST. I tried changing the timezone to something else and changed it back but same effect.
willisdeezAsked:
Who is Participating?
 
Chris DentConnect With a Mentor PowerShell DeveloperCommented:

That's really rather strange. I've seen time go too fast (either because of bad motherboards or because of it being a virtual machine), but not jump by 8 hours immediately.

Chris
0
 
Mike KlineCommented:
Is this box the PDC emulator clients and member servers should sync of that.
Did you use the steps in the article below to set the external time source
http://support.microsoft.com/kb/816042
Thanks
Mike
0
 
willisdeezAuthor Commented:
The problem is no matter what NTP server I use or whatever setting, the clock is always +8 hrs. Like right now it is 11:24PM PST and the server shows 7:24AM PST. If I change it to GMT 0 it will show 2:24PM GMT 0
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
willisdeezAuthor Commented:
I just downloaded rocket time and disabled all windows time services. It's still a very odd and troubling problem
0
 
Chris DentPowerShell DeveloperCommented:

Quite an odd problem...

> I have W32time enabled to sync to time.microsoft.com

Is that on your PDC Emulator or is AD not involved at all?

There are a few more registry keys you'd have to set on the client to stop is syncing over the domain hierarchy when using the Windows Time service.

Does it show the same discrepancy (local +8) regardless of time zone selected on the time provider? It should be passing out time in UTC, so the local time zone shouldn't matter at all, doesn't hurt to look though.

Chris
0
 
willisdeezAuthor Commented:
Yes this is a PDC emulator and yes no matter what timezone i set it goes +8... so GMT 0 would be +8 of the actual time. Even using rocket time it changes the time to the correct time, and the server changes itself back and it just cycles. I'm just going to rebuild it but it's very strange.
0
 
willisdeezAuthor Commented:
VMware ESX did not have NTP enabled
0
 
russdavisdotcomCommented:
Anytime you see time off by some weird amount (14 minutes) and it keeps setting the time back when you change it, always stop and see if you're on a virtual guest. Usually it's that the host doesn't have time sync set properly, or, in my case, I've found that the hyper-v host was looking at a hyper-v guest for time and then the guest was setting it's time to the host through integration services. The loop caused the time to increment because of timing differences until it stretched out of the kerberos window and caused auth problems.
0
 
magapieCommented:
I'm having the same problem. It is always off by one day. It's just a workgroup server right now. Just rebuilt it nothing on it now.
0
 
magapieCommented:
Change the settings on hyper-v and it's fixed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.