• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 737
  • Last Modified:

format of the initialization string does not conform to specification starting at index 0

I'm trying to create a connection to a microsoft access database file (.mdb) in my App_Data folder.  When I go to the solution explorer and try to create a new connection, I click the change button and select Microsoft Access Database File.  The next screen prompts me to enter the connection string manually, but I continue to get the error "format of the initialization string does not conform to specification starting at index 0"

See the attached screeshot of the screen where I have to manually enter the connection string.

Any ideas what the problem is?

Thanks.
screenshot.png
0
-Dman100-
Asked:
-Dman100-
  • 2
1 Solution
 
drypzCommented:
Hi! Have you tried to change your connection string? something like

Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\RGN.mdb;User Id=admin;Password=;

You can change the Data Source where your db located.
0
 
-Dman100-Software ConsultantAuthor Commented:
Hi drypz,

I tried modifying the connection string and adding the full path to the access database:

Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Documents and Settings\Dwayne\My Documents\Visual Studio 2008\Projects\Sample Code\Projects\Web Apps\ConfigureLocalAccessConnection\App_Data\RGN.mdb;User Id=admin;Password=;

I still got the same error message.
0
 
drypzCommented:
Hi! Try to download and install the latest MDAC version from microsoft.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now