Solved

How can I configure the Suse Linux router to allow me to connect to the printer?

Posted on 2009-05-11
3
915 Views
Last Modified: 2013-12-05
Hi
I am trying to configure what I thought was straight forward simple routing, but I can't get it to work!!

I have two pc's on a common ethernet switched network connected to my ADSL router as follows...

WinPC     172.16.6.2   gw 172.16.16.1
LinuxPC router (Sues Linux) dual NICS     172.16.6.1,  10.0.0.20  gw 10.0.0.254
Printer 10.0.0.17
ADSL router 10.0.0.254

The good:
- WinPC can access the internet :-)

The bad:
- WinPC can't ping 10.0.0.17!!?  How can I fix this?

LinxuPC route table and ifconfig looks like this at the moment:
Destination   Gateway         Genmask         Flags Metric Ref    Use Iface
172.26.0.0      *                       255.255.0.0     U        0      0        0  vmnet1
172.16.0.0      172.16.6.2     255.255.0.0     UG     0      0        0   eth1
link-local         *                      255.255.0.0     U        0      0        0   eth0
10.0.0.0           *                      255.0.0.0          U        0      0        0   eth0
loopback         *                      255.0.0.0         U        0      0        0    lo
default         10.0.0.254         0.0.0.0            UG      0      0        0    eth0

fileserver:~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:11:2F:46:37:05
          inet addr:10.0.0.20  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:111101 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97451 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:50656026 (48.3 Mb)  TX bytes:61382720 (58.5 Mb)
          Interrupt:193 Base address:0xa000

eth1      Link encap:Ethernet  HWaddr 00:50:04:C3:96:81
          inet addr:172.16.6.1  Bcast:172.16.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21241 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18601 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2917109 (2.7 Mb)  TX bytes:22184847 (21.1 Mb)
          Interrupt:209 Base address:0xac00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:23479 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23479 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3627799 (3.4 Mb)  TX bytes:3627799 (3.4 Mb)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:C0:00:01
          inet addr:172.26.0.1  Bcast:172.26.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:153 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

I feel that the issue must be with the linuxPC...I look forward to the expert's advice.
0
Comment
Question by:blokeman
  • 2
3 Comments
 
LVL 3

Assisted Solution

by:osintsev
osintsev earned 200 total points
ID: 24353517
Try to enable IP Forwarding on the Suse Linux router. It can be done via YaST, on the left, click NETWORK SERVICES, then select ROUTING, in the "Routing Configuration" window tick the "Enable IP Forwarding" box and save.

Or, much easier to do through the shell (run this from root):

# echo 1 > /proc/sys/net/ipv4/ip_forward
0
 
LVL 3

Assisted Solution

by:osintsev
osintsev earned 200 total points
ID: 24353794
I have missed something important, WinPC must have a route to 10.0.0.17 (or the whole subnet) via 172.16.6.1 (your Suse router), otherwise all traffic will go to the default router (172.16.16.1 in your description). It is easy to debug by run `tracert 10.0.0.17` from WinPC
0
 

Accepted Solution

by:
blokeman earned 0 total points
ID: 24354993
The YAST "Enable IP forwarding" was enabled.

WinPC's gateway is 172.16.16.1 which is a router connected to the 10.x.x.x network so it should be fine with that.

I tried tracert from the WinPC earlier but it did not help.  I can tracert/ping anything except the printer 10.0.0.17.:

C:\>tracert 10.0.0.20                       #linuxPC

Tracing route to 10.0.0.20 over a maximum of 30 hops

  1     1 ms     1 ms     1 ms  10.0.0.20

Trace complete.

C:\>tracert 10.0.0.254   #ADSL router

Tracing route to home.gateway [10.0.0.254]
over a maximum of 30 hops:

  1     1 ms     1 ms    <1 ms  172.16.6.1    #The linux router appears to work fine.
  2     1 ms     1 ms     1 ms  home.gateway [10.0.0.254]

Trace complete.
C:\>tracert 10.0.0.17    #I had to kill this as it was going nowhere.

Tracing route to 10.0.0.17 over a maximum of 30 hops

  1    <1 ms     1 ms    <1 ms  172.16.6.1
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7     *        *        *     Request timed out.
  8     *        *        *     Request timed out.
  9     *        *        *     Request timed out.

After looking broader I found the problem!  The printer has worked fine for years on the 10.x.x.x network and I only experienced problems after adding my WinPC on the 172.16.x.x network.  This made me think that I just had an issue with my new router setup, BUT it was the printer itself!!  It's gateway was the IP of the old ADSL router 10.0.0.139, which doesn't exist anymore, and so the printer could never return any communication to the WinPC because it couldn't route to it.  So I set the printer gateway to 10.0.0.254 and all is working!!!  :-)

Even though I solved the problem myself,  anyone who tries to help and used some brain cycles deserves credit.  Thanks OSINTSEV
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
cisco ubr7200 problem with  interface Wideband-Cable 1 36
Can 16Mbps internet speed work on this line ? 4 61
eBGP policy and ACL in interface 7 45
WAN Site Edge Routers 15 49
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now