Solved

Remote Access VPN on Cisco ASA not connecting at Phase 1

Posted on 2009-05-11
5
4,267 Views
Last Modified: 2012-05-06
Hi,

I am trying to set up a remote access VPN on a Cisco ASA 5505 but I'm getting errors.

The ASA does not terminate on a public IP, instead the outside interface is 192.168.0.2 . A Cisco 815 Router from the ISP is then attached to the outside interface with the IP 192.168.0.1, ie 192.168.0.1 is the default gateway for the ASA.
The ISP router then has one public IP for itself and another public IP, lets say 200.1.1.1 is configured on the router to NAT to 192.168.0.2 .

The ASA is set up for NAT-T and VPN over UDP. Ports 4500 and 500 has been allowed as incoming connections to the outside interface.

The problem is that a lot of erors are logged when trying to connect:

|May 11 2009|06:39:34|713903|||Group = DefaultRAGroup, IP = 41.182.118.241, Error: Unable to remove PeerTblEntry
3|May 11 2009|06:39:34|713902|||Group = DefaultRAGroup, IP = 41.182.118.241, Removing peer from peer table failed, no match!
7|May 11 2009|06:39:34|713906|||Group = DefaultRAGroup, IP = 41.182.118.241, sending delete/delete with reason message
7|May 11 2009|06:39:34|713906|||Group = DefaultRAGroup, IP = 41.182.118.241, IKE SA AM:a36202c5 terminating:  flags 0x0100c001, refcnt 0, tuncnt 0
7|May 11 2009|06:39:34|715065|||Group = DefaultRAGroup, IP = 41.182.118.241, IKE AM Responder FSM error history (struct &0x3eb8940)  <state>, <event>:  AM_DONE, EV_ERROR-->AM_BLD_MSG2, EV_PROCESS_SA-->AM_BLD_MSG2, EV_GROUP_LOOKUP-->AM_BLD_MSG2, EV_PROCESS_MSG-->AM_BLD_MSG2, EV_CREATE_TMR-->AM_START, EV_RCV_MSG-->AM_START, EV_START_AM-->AM_START, EV_START_AM
7|May 11 2009|06:39:34|713906|||IP = 41.182.118.241, All IKE SA proposals found unacceptable!
7|May 11 2009|06:39:34|713906|||Group = DefaultRAGroup, IP = 41.182.118.241, All SA proposals found unacceptable
7|May 11 2009|06:39:34|713236|||IP = 41.182.118.241, IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + NOTIFY (11) + NONE (0) total length : 596
7|May 11 2009|06:39:34|715047|||Group = DefaultRAGroup, IP = 41.182.118.241, processing IKE SA payload
7|May 11 2009|06:39:34|715049|||IP = 41.182.118.241, Received Cisco Unity client VID
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing VID payload
7|May 11 2009|06:39:34|715049|||IP = 41.182.118.241, Received NAT-Traversal ver 02 VID
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing VID payload
7|May 11 2009|06:39:34|715064|||IP = 41.182.118.241, IKE Peer included IKE fragmentation capability flags:  Main Mode:        True  Aggressive Mode:  False
7|May 11 2009|06:39:34|715049|||IP = 41.182.118.241, Received Fragmentation VID
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing VID payload
7|May 11 2009|06:39:34|715049|||IP = 41.182.118.241, Received DPD VID
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing VID payload
7|May 11 2009|06:39:34|715049|||IP = 41.182.118.241, Received xauth V6 VID
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing VID payload
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing ID payload
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing nonce payload
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing ISA_KE payload
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing ke payload
7|May 11 2009|06:39:34|715047|||IP = 41.182.118.241, processing SA payload
7|May 11 2009|06:39:34|713236|||IP = 41.182.118.241, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + SA (1) + KE (4) + NONCE (10) + ID (5) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 857

The problem seems to be with "All SA proposals found unacceptable". I also think that the issues is maybe because the VPN client does not connect straight to 192.168.0.2 but instead it connects to 200.1.1.1 which is then NATed. The ASA does not know anything about 200.1.1.1, although in the access list I did specify the outside interface instead of an IP.

A lot of people say to disable PFS - I have done so but it didn't help.

Any idea? - Config is attached as "code":
:
ASA Version 7.2(4) 
!
hostname blah
domain-name blah.blah
enable password DO8Oc533.vJWmhVe encrypted
passwd DO8Oc533.vJWmhVe encrypted
names
name 192.168.1.1 lrserver1
name 192.168.1.2 lrserver2
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.250 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.0.2 255.255.255.0 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
banner motd $
banner motd Only attempt to access this device, network or server if you are authorized to do so. All access will be logged and unauthorized access will be prosecuted.
ftp mode passive
dns server-group DefaultDNS
 domain-name blah
object-group network lrdwhk-lan
 network-object 192.168.1.0 255.255.255.0
object-group service inside_in_ports_tcp tcp
 port-object eq www
 port-object eq 8080
 port-object eq https
 port-object eq pop3
 port-object eq smtp
 port-object eq ftp
 port-object eq ftp-data
 port-object eq domain
object-group service inside_in_ports_udp udp
 port-object eq domain
object-group service outside_in_ports_tcp tcp
object-group service outside_in_ports_udp udp
 description NAT-T VPN POrt
 port-object eq 4500
access-list inside_in extended permit tcp object-group lrdwhk-lan any object-group inside_in_ports_tcp 
access-list inside_in extended permit udp object-group lrdwhk-lan any object-group inside_in_ports_udp 
access-list outside_in extended permit udp any any object-group outside_in_ports_udp 
pager lines 24
logging enable
logging asdm debugging
mtu inside 1500
mtu outside 1500
ip local pool LRDWhkRAVPNIPPool 192.168.1.200-192.168.1.210 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
access-group inside_in in interface inside
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa-server LRDWhkRAVPNAAA protocol ldap
aaa-server LRDWhkRAVPNAAA (inside) host lrserver1
 timeout 5
 ldap-base-dn OU=Users,OU=LRD,DC=LR,DC=local
 ldap-scope subtree
 ldap-login-password *
 ldap-login-dn asadsaccess
 server-type microsoft
aaa-server LRDlrserver1IAS protocol radius
aaa-server LRDlrserver1IAS (inside) host lrserver1
 key blah
 acl-netmask-convert auto-detect
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-192-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto ca trustpoint LRDASA1
 enrollment terminal
 crl configure
crypto isakmp enable outside
crypto isakmp policy 10
 authentication crack
 encryption aes-192
 hash sha
 group 5
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
ssh version 2
console timeout 0
dhcpd auto_config outside
!
dhcpd address lrserver2-192.168.1.129 inside
!
 
group-policy LRDWhkRAVPN internal
group-policy LRDWhkRAVPN attributes
 dns-server value 192.168.1.2 192.168.1.1
 vpn-tunnel-protocol IPSec 
tunnel-group LRDWhkRAVPN type ipsec-ra
tunnel-group LRDWhkRAVPN general-attributes
 address-pool LRDWhkRAVPNIPPool
 authentication-server-group LRDWhkRAVPNAAA
 default-group-policy LRDWhkRAVPN
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:cdf340ba201503fafd6e53fec788a982
: end
asdm image disk0:/asdm-524.bin
no asdm history enable

Open in new window

0
Comment
Question by:schoemans
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 33

Accepted Solution

by:
MikeKane earned 500 total points
ID: 24355749
The client has a limited number of supported proposals depending on its version.   For example
http://www.cisco.com/en/US/docs/security/vpn_client/cisco_vpn_client/vpn_client46/administration/guide/vcAch8.html#wp1168133

Your AES-192 would not be supported.  

Just simply double check the supported proposals for your version and match it up with the ASA.  

0
 

Author Comment

by:schoemans
ID: 24362252
Thanks MikeKane,

You got me a step further - so stupid of me to assume that the Cisco client and the ASA will support all policies.

I do however have the next issue now:
4|May 12 2009|01:22:58|713903|||Group = DefaultRAGroup, IP = 196.3.94.225, Error: Unable to remove PeerTblEntry
3|May 12 2009|01:22:58|713902|||Group = DefaultRAGroup, IP = 196.3.94.225, Removing peer from peer table failed, no match!
7|May 12 2009|01:22:58|713906|||Group = DefaultRAGroup, IP = 196.3.94.225, sending delete/delete with reason message
7|May 12 2009|01:22:58|713906|||Group = DefaultRAGroup, IP = 196.3.94.225, IKE SA AM:f89a796d terminating:  flags 0x0104c001, refcnt 0, tuncnt 0
7|May 12 2009|01:22:58|715065|||Group = DefaultRAGroup, IP = 196.3.94.225, IKE AM Responder FSM error history (struct &0x3f37ad0)  <state>, <event>:  AM_DONE, EV_ERROR-->AM_SND_MSG2, EV_SND_MSG-->AM_SND_MSG2, EV_START_TMR-->AM_BLD_MSG2, EV_BLD_MSG2_TRL-->AM_BLD_MSG2, EV_SKEYID_OK-->AM_BLD_MSG2, NullEvent-->AM_BLD_MSG2, EV_GEN_SKEYID-->AM_BLD_MSG2, EV_BLD_MSG2_HDR
7|May 12 2009|01:22:58|713236|||IP = 196.3.94.225, IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + SA (1) + KE (4) + NONCE (10) + ID (5) + HASH (8) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NAT-D (130) + NAT-D (130) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 412
7|May 12 2009|01:22:58|715048|||Group = DefaultRAGroup, IP = 196.3.94.225, Send Altiga/Cisco VPN3000/Cisco ASA GW VID
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing VID payload
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing Fragmentation VID + extended capabilities payload
7|May 12 2009|01:22:58|713906|||Group = DefaultRAGroup, IP = 196.3.94.225, computing NAT Discovery hash
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing NAT-Discovery payload
7|May 12 2009|01:22:58|713906|||Group = DefaultRAGroup, IP = 196.3.94.225, computing NAT Discovery hash
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing NAT-Discovery payload
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing NAT-Traversal VID ver 02 payload
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing xauth V6 VID payload
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing Cisco Unity VID payload
7|May 12 2009|01:22:58|715076|||Group = DefaultRAGroup, IP = 196.3.94.225, Computing hash for ISAKMP
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing hash payload
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing ID payload
7|May 12 2009|01:22:58|713906|||Group = DefaultRAGroup, IP = 196.3.94.225, Generating keys for Responder...
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing nonce payload
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing ke payload
7|May 12 2009|01:22:58|715046|||Group = DefaultRAGroup, IP = 196.3.94.225, constructing ISAKMP SA payload
7|May 12 2009|01:22:58|715028|||Group = DefaultRAGroup, IP = 196.3.94.225, IKE SA Proposal # 1, Transform # 6 acceptable  Matches global IKE entry # 1
7|May 12 2009|01:22:58|715047|||Group = DefaultRAGroup, IP = 196.3.94.225, processing IKE SA payload
7|May 12 2009|01:22:58|715049|||IP = 196.3.94.225, Received Cisco Unity client VID
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing VID payload
7|May 12 2009|01:22:58|715049|||IP = 196.3.94.225, Received NAT-Traversal ver 02 VID
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing VID payload
7|May 12 2009|01:22:58|715064|||IP = 196.3.94.225, IKE Peer included IKE fragmentation capability flags:  Main Mode:        True  Aggressive Mode:  False
7|May 12 2009|01:22:58|715049|||IP = 196.3.94.225, Received Fragmentation VID
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing VID payload
7|May 12 2009|01:22:58|715049|||IP = 196.3.94.225, Received DPD VID
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing VID payload
7|May 12 2009|01:22:58|715049|||IP = 196.3.94.225, Received xauth V6 VID
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing VID payload
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing ID payload
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing nonce payload
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing ISA_KE payload
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing ke payload
7|May 12 2009|01:22:58|715047|||IP = 196.3.94.225, processing SA payload
7|May 12 2009|01:22:58|713236|||IP = 196.3.94.225, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + SA (1) + KE (4) + NONCE (10) + ID (5) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 857
6|May 12 2009|01:22:58|302015|196.3.94.225|192.168.0.2|Built inbound UDP connection 206 for outside:196.3.94.225/26532 (196.3.94.225/26532) to NP Identity Ifc:192.168.0.2/500 (192.168.0.2/500)
7|May 12 2009|01:22:58|609001|192.168.0.2||Built local-host NP Identity Ifc:192.168.0.2
7|May 12 2009|01:22:58|609001|196.3.94.225||Built local-host outside:196.3.94.225
7|May 12 2009|01:22:43|710005|192.168.1.41|192.168.1.255|UDP request discarded from 192.168.1.41/137 to inside:192.168.1.255/137
7|May 12 2009|01:22:42|710005|192.168.1.41|192.168.1.255|UDP request discarded from 192.168.1.41/137 to inside:192.168.1.255/137
7|May 12 2009|01:22:41|710005|192.168.1.41|192.168.1.255|UDP request discarded from 192.168.1.41/137 to inside:192.168.1.255/137
7|May 12 2009|01:22:40|710005|192.168.1.41|192.168.1.255|UDP request discarded from 192.168.1.41/137 to inside:192.168.1.255/137
7|May 12 2009|01:22:39|710005|192.168.1.41|192.168.1.255|UDP request discarded from 192.168.1.41/137 to inside:192.168.1.255/137
6|May 12 2009|01:22:37|606001|192.168.1.41||ASDM session number 1 from 192.168.1.41 started
6|May 12 2009|01:22:37|605005|192.168.1.41|192.168.1.250|Login permitted from 192.168.1.41/1653 to inside:192.168.1.250/https for user "enable_15"

Open in new window

0
 

Author Comment

by:schoemans
ID: 24362390
Here is the client IKE debuggin log - some issues with Hash:

Cisco Systems VPN Client Version 5.0.02.0090
Copyright (C) 1998-2007 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Windows, WinNT
Running on: 5.1.2600 Service Pack 2
Config file directory: G:\Program Files\Cisco\

1      09:53:54.109  05/12/09  Sev=Info/6      IKE/0x6300003B
Attempting to establish a connection with 196.216.43.236.

2      09:53:54.125  05/12/09  Sev=Info/4      IKE/0x63000013
SENDING >>> ISAKMP OAK AG (SA, KE, NON, ID, VID(Xauth), VID(dpd), VID(Frag), VID(Nat-T), VID(Unity)) to 196.216.43.236

3      09:53:54.437  05/12/09  Sev=Info/5      IKE/0x6300002F
Received ISAKMP packet: peer = 196.216.43.236

4      09:53:54.437  05/12/09  Sev=Info/4      IKE/0x63000014
RECEIVING <<< ISAKMP OAK AG (SA, KE, NON, ID, HASH, VID(Unity), VID(Xauth), VID(Nat-T), NAT-D, NAT-D, VID(Frag), VID(?)) from 196.216.43.236

5      09:53:54.437  05/12/09  Sev=Info/5      IKE/0x63000001
Peer is a Cisco-Unity compliant peer

6      09:53:54.437  05/12/09  Sev=Info/5      IKE/0x63000001
Peer supports XAUTH

7      09:53:54.437  05/12/09  Sev=Info/5      IKE/0x63000001
Peer supports NAT-T

8      09:53:54.437  05/12/09  Sev=Info/5      IKE/0x63000001
Peer supports IKE fragmentation payloads

9      09:53:54.437  05/12/09  Sev=Warning/3      IKE/0xE3000057
The received HASH payload cannot be verified

10     09:53:54.437  05/12/09  Sev=Warning/2      IKE/0xE300007E
Hash verification failed... may be configured with invalid group password.

11     09:53:54.437  05/12/09  Sev=Warning/2      IKE/0xE300009B
Failed to authenticate peer (Navigator:904)

12     09:53:54.437  05/12/09  Sev=Info/4      IKE/0x63000013
SENDING >>> ISAKMP OAK INFO (NOTIFY:INVALID_HASH_INFO) to 196.216.43.236

13     09:53:54.437  05/12/09  Sev=Info/4      IKE/0x63000013
SENDING >>> ISAKMP OAK INFO (NOTIFY:AUTH_FAILED) to 196.216.43.236

14     09:53:54.437  05/12/09  Sev=Warning/2      IKE/0xE30000A7
Unexpected SW error occurred while processing Aggressive Mode negotiator:(Navigator:2238)

15     09:53:54.437  05/12/09  Sev=Info/4      IKE/0x63000017
Marking IKE SA for deletion  (I_Cookie=C033927946677A6D R_Cookie=F19ECAAD19F85899) reason = DEL_REASON_IKE_NEG_FAILED

16     09:53:55.046  05/12/09  Sev=Info/4      IKE/0x6300004B
Discarding IKE SA negotiation (I_Cookie=C033927946677A6D R_Cookie=F19ECAAD19F85899) reason = DEL_REASON_IKE_NEG_FAILED

17     09:53:55.093  05/12/09  Sev=Info/4      IKE/0x63000001
IKE received signal to terminate VPN connection
0
 

Author Comment

by:schoemans
ID: 24363892
Don't worry I got it sorted.

I used the domain credentials in VPN client's group credentials (because the ASA authenticates with MS Radius).

Since this is the negotitation of the security protocols, the MS credentials do not come into play yet.

Instead the tunnel-group name was used for the username and the pre-shared key for the password. It now connects. I however do not have access to internal LAN but I will make this issue a new thread since the problem related to this specific thread has been solved.

Thanks.
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 24365156
Glad its working.   And accessing internal lans is just a matter of getting the ACLs in order.  

0

Featured Post

Is your NGFW recommended by NSS Labs?

Ours is! NSS Labs Next Generation Firewall Test gives the WatchGuard Firebox M4600 a "Recommended" rating! Curious where your NGFW landed on the  Security Value Map? See the map and download the full report today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question