• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 286
  • Last Modified:

Saved passwords not working - Network Wide

I recently starting receiving complaints from users that websites they use every day no longer "Remember" them.  This problem is happening to everyone.  One primary example is https://login.salesforce.com/.  Previously, they were able to enter their e-mail address as a username, click on remember me, and then each time thereafter they no longer needed to enter their e-mail address.

I'm not sure where to start and am looking for any tips to get me going in the right directions.

Thanks,
Kirk
0
ITDeptAtPCS
Asked:
ITDeptAtPCS
  • 4
  • 3
  • 2
1 Solution
 
bootrebootCommented:
Have you made any group policy changes recently?

Which checkboxes are checked on opn one of the workstations if you go to the control panel, Internet Options. Content Tab, AutoComplete Settings?

Are you using Internet Explorer?  If so, what version?
0
 
ITDeptAtPCSAuthor Commented:
Group policy changes, not that I can think of, but this has been going on for about 2 months, so it is possible back then.  Anything I should check for?

Everyone is on IE7.

Use AutoComplete for:
Address bar - Checked
Browsing history - Checked
Favorites - Checked
Feeds - Not checked
Use Windows Search for better results - Checked
Forms - Checked
User names and passwords on forms - Checked
Ask me before saving passwords - Checked
0
 
johnb6767Commented:
start>run>services.msc

Make sure that the Protected Storage service is started, and set to Automatic.....
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Next, run regedit, find this key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
"DisablePwdCaching"

Make sure the above value is nto present, or set to 0.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Disable Storage of Credentials and .NET Passwords
http://www.pctools.com/guides/registry/detail/1286/

Make sure this isnt present either....
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
How to perform advanced clean-boot troubleshooting in Windows XP
http://support.microsoft.com/kb/316434

In MSConfig
I would disable all items under Startup, and retest.....
If it still fails, disable all non MS services....
If it still fails, disable the services, except for the Protected Storage. Then retest....

0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
johnb6767Commented:
This has been happening way too much lately. Probably triggered by an update recently. How are you handling MS Updates?
0
 
bootrebootCommented:
i just took a look at the Salesforce.com website and they have AUTOCOMPLETE="OFF" disabled in their logon form.  This isn't a problem with your network, it's Salesforce.com's security design.  I know that there are external password manager that will bypass this setting, but i don't know of any off the top of my head.  I ususally use the ones that come with my laptopss
0
 
ITDeptAtPCSAuthor Commented:
The Protected Storage service was started and set to automatic.
In the first key, I was able to browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\ but did not have a Network to dive deep into.

The registry entry in the first link you provided was set to 0...enable storage.

Updates are being handled by a WSUS server.
0
 
ITDeptAtPCSAuthor Commented:
Thanks bootreboot.  Would this just prevent them from having their username filled out?  Or prevent them from having their username and password filled out for them already (when IE asks "Do you want to save this password?)?  

On the computer I've been testing with, no web pages are asking me to save my passwords anymore.  

Another computer with a fresh XP install (no updates) allows me to save passwords and works like a charm.  Tomorrow I'll install the updates and see if one breaks it.  I don't think one will, I just think something is wrong with my install of IE.

My HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\ FormSuggest PW Ask is set to yes.
0
 
bootrebootCommented:
It would prevent the saving of the username and the password.... assuming that the web developer did not save the username in a cooke.

I'm not sure how familair you are with HTML, so i apologize if i'm going over something that you may already be familiar with.  A web developer can place any number of forms within a web page.  Furthermore, they can place any number of fields (text boxes, check boxes, radio buttons, drop down lists, buttons) within a form.  The autocomplete=off tag can be applied at the form level or to individual fields.  when it is applied at the form level, it affects all items within the form.  

Here's some microsoft info about Autocomple=off http://msdn.microsoft.com/en-us/library/ms533032(VS.85).aspx 

Here's a good tutorial about Autocomeple: http://www.geocities.com/technofundo/tech/web/ie_autocomplete.html
0
 
ITDeptAtPCSAuthor Commented:
Excellent, thanks for the additional resources bootreboot.

I dug into Salesforce a little bit more to figure out why they would do that.  For anyone else that has users complaining that salesforce.com no longer remembers their username:

"If you have checked the "Remember User Name" box on the Salesforce login page but your User Name is not, in fact, being saved, have your administrator take these steps:  Setup | Administration Setup | Security Controls | Session Settings | Check the "Enable caching and auto complete on login page" checkbox & Save.  Anyone in your organization who checks the "Remember User Name" box on the login page will now have their User Name saved."

0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now