Linux drivers for SuperMicro AOC-SASLP-MV8

Can someone help me get or build Linux drivers for SuperMicro AOC-SASLP-MV8. I am trying to use in and OpenFiler machine. I no nothing about building drivers and very little about Linux.
DMooringAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
ai_ja_naiConnect With a Mentor Commented:
what instructions do not work? Have you installed make and gcc, first (the basic tools for compiling)?
0
 
ai_ja_naiCommented:
Do you need additional drivers? Isn't the card working out-of-the-box?
0
 
ai_ja_naiCommented:
Anyway, this documents explains how to install the software for linux (http://www.supermicro.com/manuals/other/AOC-SASLP-MV8.pdf)
0
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

 
DMooringAuthor Commented:
The drivers on supermicro's site do not seem to work with Openfiler which runs on rPath linux.

The instructions where as followed. After creating the disk.

Insert driver disk into floppy, and follow below steps:

1) login as root
2) mount -r /dev/fd0 /media/floppy
3) cd /media/floppy; sh ./install
4) cd ~; umount /media/floppy

0
 
ai_ja_naiCommented:
Explain

>the drivers on supermicro's site do not seem to work
0
 
DMooringAuthor Commented:
When I try to install I get.
ls; /lib/modules/2.6.18-19*; No such file or directory

I try changing the BASE_VER line in the install file to BASE_VER=2.6.29 and tried intalling again.
I get this.
Generic Protection Error



0
 
DMooringAuthor Commented:
I found this artical.
http://www.hardforum.com/showthread.php?s=de8d2a36946192cbba9c4f584e985b20&p=1034071298#post1034071298

I tried to follow the instruction.

# Be sure that all the required files are available
apt-get install build-essential subversion module-assistant
module-assistant prepare

The commands above did not run on my system.

# Make a directory, and get the svn files
mkdir sas
cd sas
svn co https://scst.svn.sourceforge.net/svnroot/scst

# Remove the old driver ( or move out out of the way. Note the directory will differ based on your kernel version ).
rm /lib/modules/2.6.26-1-openvz-amd64/kernel/drivers/scsi/mvsas.ko

# Enter the directory to the correct subdir, and make the driver
cd /sas/scst/trunk/mvsas_tgt/
/sas/scst/trunk/mvsas_tgt# make

I could not get the last line to run.
0
 
ai_ja_naiCommented:
FIrst of all, what system do you have? That guide is for Debian based distros
0
 
DMooringAuthor Commented:
Trying to load driver on an Openfiler machine which runs on rPath Linux.
I have not found any instruction on building drivers for rPath.
0
 
ai_ja_naiCommented:
Ok. You need to compile it from source. The guide I liked above provides the tutorial to build from source, refer to the section "3-2 Adding the Driver into an Existing System"
0
 
DMooringAuthor Commented:
The problem has to do with compiling on rPath Linux. The instructions that came with the card do not work. Does anyone have any experience building drivers on rPath?
0
 
DMooringAuthor Commented:
Ran out of time and gave up. Got another card that works.

Thanks all
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.