Publishing error with Dreamweaver CS4

I am using Dreamweaver CS4 to create a new website.  I am using Webdav to publish the site to my Apache web server.  I have other users using the same software publishing to the same server with no problem.

When I try to upload my site, I get several files that do not upload.  I get the following message on the files that do not copy:

error occurred - an HTTP error occurred - cannot put file.jpg.  Access denied.  The file may not exist, or there could be a permission problem.  Make sure you have proper authorization on the server and the server is properly configured.

The rest of my files upload without a problem.  What's happening here?

Thanks.
bkestingAsked:
Who is Participating?
 
bkestingConnect With a Mentor Author Commented:
I setup a new directory on my webserver and redid the configuration of the Directory in default.conf and now it works.  Same exact configuration, but something must have been wrong with the original.

0
 
Jason C. LevineNo oneCommented:
Hi bkesting,

Is this problem limited to when you upload files in a batch or even if you try to upload the single file it won't take it?

Can you try to use FTP to load the file?
0
 
bkestingAuthor Commented:
This happens even with single, specific files.

0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Jason C. LevineNo oneCommented:
Okay, what happens if you try FTP?
0
 
bkestingAuthor Commented:
I have never tried it.....I don't have FTP setup on my webserver.
0
 
Jason C. LevineNo oneCommented:
Okay, it would have been nice to have that as a comparison.

What I think is going on is the WebDav permissions are messed up.  Can you reconfigure them?
0
 
bkestingAuthor Commented:
My config for the site in question on my Apache server is as follows:


<Directory "/home/www/website">
     DAV On
     AllowOverride AuthConfig Limit
     Options None
     <Limit COPY DELETE LOCK MKCOL MOVE PATCH PROPFIND PROPPATCH PUT UNLOCK>
          AuthType Basic
          AuthName "Website WebDAV"
          AuthUserFile /etc/apache2/htusers
          Require valid-user
     </Limit>
     Order allow,deny
     Allow from all
</Directory>
 
What should I change?

Open in new window

0
 
Jason C. LevineNo oneCommented:
Hmmm,

That looks okay.  Is the site using Check-In/Check-Out?
0
 
bkestingAuthor Commented:
Check In/Check out is currently disabled, but I believe it still did this when I had it enabled too.
0
 
Jason C. LevineNo oneCommented:
Is this your server or a hosted one?
0
 
bkestingAuthor Commented:
It is my own server.
0
 
bkestingAuthor Commented:
Anyone have any thoughts?
0
 
Jason C. LevineNo oneCommented:
Sorry.

I cannot see a reason from the information given why DW would not put that file.  The only thing I can think of is some weird security setting or the file is corrupt or some other application is attempting to access that file at the same time and locking it.
0
 
Jason C. LevineNo oneCommented:
Weird.  Glad it is working for you now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.