?
Solved

Microsoft Commuications Server 2007 R2

Posted on 2009-05-11
5
Medium Priority
?
1,717 Views
Last Modified: 2013-11-29
Hi Experts

I am trying to install Microsoft Communications Server, but when trying to install, it attempts to install the Web components.
Near the end of the installation this error message appears:

Failed to find node: /configuration/system.webServer/security/authentication/windowsAuthenication in XML file: C:\Windows\system32\inetsrc\config\applicationHost.config, system error: -2147020584

Can anyone suggest a fix to this?
I have enabled Windows Authentication on the default website and completed an IISReset, but this doens't seem to resolve the issue.

Anyone had this issue?
I'm not sure if this is an SBS 2008 issue, as this is not a 2008 Standard install.
Suggestions greatly appreciated.
Thanks,
Mark

0
Comment
Question by:MarkMichael
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 4

Expert Comment

by:BillCarlin
ID: 24359884
Assuming you copied and pasted the error I see that it is looking for \system32\intesrc..Normally it should be looking for \inetsrv.  Just wanted to clarify before moving on.
0
 
LVL 15

Author Comment

by:MarkMichael
ID: 24362835
Hi

No, I could not copy and paste the error message.
Yes, I made a typo. It's inetsrv on the error message.

Thanks
0
 
LVL 4

Accepted Solution

by:
BillCarlin earned 2000 total points
ID: 24368374
The issue should be caused by some corrupt data in C:\Windows\System32\inetsrv\config\applicationHost.config which makes the configuration XML file no longer well-formed and IIS cannot parse it.
Please check if there is a previous backup under:
C:\Windows\System32\inetsrv\backup\* . If there is, stop IIS services and copy the backup applicationHost.config and overwrite current corrupt one in \inetsrv\config .
If there isn't any available backup file, please stop IIS services first and try uninstalling it again. Regardless if the uninstallation succeeds, please manually delete the \inetsrv directory under C:\Windows\System32 . Then please reboot the server to perform a clear reinstallation of IIS

Take a look at this thread which will also direct how to make a back up of IIS.
http://www.issociate.de/board/post/482067/IIS7_won't_run_or_uninstall.html
0
 
LVL 15

Author Comment

by:MarkMichael
ID: 24388186
Thanks for that.

That worked for me...
0
 

Expert Comment

by:freebluehat
ID: 24629897
I am having the same issue but i uninstall IIS reinstalled it and still the same problem any other ideas
0

Featured Post

Setting up LaraDock for Laravel

Learn how to set up LaraDock in a Laravel project - LaraDock gives us an easy way to run a Laravel application using Docker in a single command.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Know what services you can and cannot, should and should not combine on your server.
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question