Solved

SQL 2005 Column-Level Security

Posted on 2009-05-11
10
647 Views
Last Modified: 2012-05-06
How can I apply column level security on my tables? I understand that is easily done on a view but I cannot see how to do it on the tables.
0
Comment
Question by:Bill Warren
10 Comments
 
LVL 75

Expert Comment

by:Aneesh Retnakaran
ID: 24357881
0
 
LVL 142

Assisted Solution

by:Guy Hengel [angelIII / a3]
Guy Hengel [angelIII / a3] earned 100 total points
ID: 24357893
you can also grant column-specific permissions per column in sql server.

listing: sp_column_privileges : RTFM:
http://msdn.microsoft.com/en-us/library/ms187765.aspx

the link has also in "see also" the links to GRANT and REVOKE

it's also possible to do it in the GUI ...
0
 
LVL 9

Expert Comment

by:ezraa
ID: 24357998
Use the GRANT, REVOKE, and DENY statements:

example - don't allow username to select the [MyColumn] column from the table [MyTable]:

revoke select ([MyColumn]) on [MyTable] to username

Open in new window

0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 

Author Comment

by:Bill Warren
ID: 24358476
How is it done in the GUI You ean in the Management Studio? Also if not in the GUI... where do I go to apply the Grant, Revoke, and Deny statements?
0
 
LVL 9

Accepted Solution

by:
ezraa earned 400 total points
ID: 24358803
right click on the table and choose properties -> Permissions

on the bottom you should see the button "Column Permissions"

You need to click (or add) a role, then you can select a permission and select the columns that has (or is revoked) that permission.
0
 

Author Comment

by:Bill Warren
ID: 24358892
When I right click on a table I don't have permissions see the screenshot. The version is MS SQL 2005 Standard SP2
screen.bmp
0
 

Author Comment

by:Bill Warren
ID: 24358905
Oh okay i think I found it under properties
0
 
LVL 9

Expert Comment

by:ezraa
ID: 24358913
Right click and click on Properties

Then in the window that opens you should see permission on the left side.
0
 
LVL 9

Assisted Solution

by:ezraa
ezraa earned 400 total points
ID: 24358964
Your looking for this:
perms.jpg
0
 

Author Closing Comment

by:Bill Warren
ID: 31580278
Thanks a bunch everyone
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
This article shows gives you an overview on SQL Server 2016 row level security. You will also get to know the usages of row-level-security and how it works
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Via a live example, show how to shrink a transaction log file down to a reasonable size.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question