• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1334
  • Last Modified:

RDP, XP to XP while preventing a Man in the Middle attack

XP to XP RDP while preventing the possibility Man in the middle attack.

 I am working inside a network and can get RDP to work just fine. We only use RDP inside our network or when connecting with a VPN.  What I am trying to do secure the connections using certificates ? if that is the way to do it ?.  I have upgraded my RDP to 6.0.6001 on my client machines and I have been able to get the certificates to be passed to me from Server2003 and Vista.  The issue is getting the XP computers to pass certificates or authenticate to the server when connecting to another XP machine.  

If anyone has set this up or knows how to do it please let me know.

This is what I have tried:
http://support.microsoft.com/kb/895433

Created a CA certificate
Made sure that the computers have the certificate as trusted.
Modified the client registry on the XP computers that I am testing.
Tried to connect using authentication but have not had any luck.  
I can get the XP cleints to connect to each other without using server authentication.
0
PJC777
Asked:
PJC777
  • 5
  • 2
2 Solutions
 
PJC777Author Commented:
Here is the error that I am getting.
0
 
PJC777Author Commented:
How do you get the XP computer to authenticate with your certificate server when connecting to another XP computer? Is that how it should work?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
IanThCommented:
you did not attach your error btw
0
 
PJC777Author Commented:
Take two on the error...
0
 
PJC777Author Commented:
My screen print isnt working so here is the error:

Remote desktop connection.

Your remote desktop connection failed because the remote computer cannot be authenticated.

Your computer's setting do not allow connection to this remote computer because it cannot be identified. Either it is running a version of windows earlier then Windows Vista, or is not configured to support server authentication.

For a assistance contact your network administrator or the owner of the remote computer.
0
 
SysExpertCommented:
It sounds like certificates are not supported on XP. Need Vista or newer

Use VNC instead....

0
 
PJC777Author Commented:
Still unsure if it is posible to use certificates while connecting an XP computer to an XP computer using RDP.  VNC works but then it's an application that needs to be installed and configured per computer. This has been a requirement pushed to us through an IS audit. Thanks for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now