Solved

Cannot get Web Applications and default webite to run at the same time in sbs 2008

Posted on 2009-05-11
10
686 Views
Last Modified: 2012-06-27
I am catching hell with this sbs 2008 setup. I got the certificate error resolved, then I ran updates. Once the server came back up, I could not get into owa, or RWW. When I went into IIS, realized that SBS web applications was not running. When I tried to start it, I got an error that said that it could not start because something else was using the port. So as a test, I stopped default web site, and then I was able to get sbs web applications to start, when I log into RWW, it kept prompting for credentials. All this happened after doing updates. How do I get sbs web applications and default website to run at the same time. I am running out of time,  please help me.
0
Comment
Question by:xzay1967
  • 6
  • 4
10 Comments
 
LVL 22

Assisted Solution

by:cj_1969
cj_1969 earned 500 total points
ID: 24363855
If this is 2 different web servers then you are only going to be able to use one of them on the default port of 80.

To get both working at the same time one of them will either have to be on a different port or you could add a second IP address to the NIC and bind both IIS and the other app to a unique IP address.
0
 

Author Comment

by:xzay1967
ID: 24364133
This is sbs 2008, and there is only one server. Attached is my screenshot that shows my port settings. I am not sure which needs port 443 (I think that is the conflicting port). If I try to remove port 443 from the bindings, I get a message that says that removing it will cause other apps in iis to stop working because they are both binded to the same cert. Sure wish there was system restore on servers. I ran the fix my network wizard a few times, and it did not help. I even ran the best practice analyzer to see if it found anything, it did not.
my-settings.jpg
0
 
LVL 22

Assisted Solution

by:cj_1969
cj_1969 earned 500 total points
ID: 24364205
Symantecs here ... each of those listings in your screenshot is a site ... yes, one web server but multiple sites, each site needs to have a unique IP or Port (typically).
You could try configuring a host header option on the Default Web Site and then see if it will start up.

If you look at the Client Deployment App and Web Applications, my guess is that the name or domain reference after the initial port reference is a host header reference.  If you look atht e SBS SharePoint entry, there is no name reference in this line ... this looks like this is in direct competition with the default site.

Try changing the port 80 on the default site and all should come up.
You could also try leaving the port and adding a host header entry and see if this lets the site come up.
0
 

Author Comment

by:xzay1967
ID: 24366089
I hear what you are saying, and it makes perfect sense. I removed port 443 from the sbs web applications, and I lost everything. I could not get any of the websites of come up. If I try to browse port 80 (while in IIS) I get the welcome to IIS page in various languages. If I try to browse to rww or owa from outside the network, I get the web page is unavailable. Even when I add port 443 back to the sbs applications, nothing worked. I tried moving up the default.aspx document to the top (thinking that the default page was not there), nothing worked. I got the sites to work again by clicking on sites (on the left pane), and selecting the option to set website defaults (right pane). That allowed the sites to work again, but I still cannot get default website and sbs web applications to run at the same time. What is also confusing is that the cert works fine on sbs web applications, but if I browse port 443 on default website (within iis), I get an untrusted certificate error. I thought both sites used the same cert. I can connect to rww and owa from outside with no problem (basically no untrusted certificate error is generated). I am at my wits end guys. if I try to remove or change the cert for the default website, I get the warning that another site is binded to the same cert. Does the default website need a different cert than the sbs web applications, or should go thru the process of doing another csr via the Add a trusted certificate wizard that is a part of the sbs management console? This might address the cert issue, but what about the port issue? Like I said, I know the port conflict is 443, because when I removed it from the sbs web applications, I can start both of them. Or maybe I need to remove 443 from default website. What is my next move?
0
 

Author Comment

by:xzay1967
ID: 24366775
One other thing I noticed, there is not hostname associated with the default website.
my-settings.jpg
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 22

Accepted Solution

by:
cj_1969 earned 500 total points
ID: 24367686
I believe you have to use the same cert for all sites within an IIS instance.
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/596b9108-b1a7-494d-885d-f8941b07554c.mspx?mfr=true

If the server is accessible via the internet, try adding a host header to the default website and see if it will start up.  If not, DO NOT delete the port references, try changing the port that the default site is using ... try 8080 and 8443 (these are standard ports for Apache).

This should allow the site to start up.
0
 

Author Comment

by:xzay1967
ID: 24368776
What host header do I use? I know it may sound stupid or even vague, how do I do that? Now I  looked at another client I setup, except they had sbs 2003, and the default website is using ports 80 and 443, and the companyweb is listed in the site list. Oh before I forget, here is my current status:
I can access owa, and rww remotely, however whenever I click the link to access the company website, I prompted for a username and password. The option to connect to a computer is not there either.Even internally, I cannot access the companyweb without being prompted for a username and password. I looked at the certification path for certificate assigned to the default website, and the sbs web applications, and they are both the same. should I go thru the add a trusted certificate wizard from the sbs management console again? maybe that will apply the cert to both sites simultaneously. Also, I honestly don't think that the sbs web applications need port 443, but I am just guessing. Here is a thought:
Remove port 443 from the sbs web applications
Reapply the cert via the add a trusted certificate in the sbs management console.
How does that sound?
0
 

Author Comment

by:xzay1967
ID: 24371334
I was able to get the two sites to start by removing port 443 from the default website, and then I used the add trusted certificate wizard to re-apply the certificate. Now I  can access both owa and rrw, however, when I attempt to access companyweb, I keep getting the username and password dialog box. Another thing is that the option to connect to a computer is not there in rww anymore.
0
 
LVL 22

Assisted Solution

by:cj_1969
cj_1969 earned 500 total points
ID: 24374039
If you are getting prompted for credentials then Windows Authentication is selected in the Security tab of the properties for the default site.  Unselect it and just leave anonymous enabled and it should work.

As for rww ... I know nothing about it so unfortunately I won't be able to help with this part.
0
 

Author Comment

by:xzay1967
ID: 24378194
Thanks cj, for all your attempts. I was able to get everything fixed, except for the constant prompting for username and password when attempting to connect to companyweb. I know what is causing it, but I guess Microsoft needs to provide a patch for that. The constant prompting is cause by kb963027. I removed it, but the issue still exist. But I know for a fact that the issue is caused by the update; I found that on MS website as well. See this blog as well: http://blog.mpecsinc.ca/2009/04/sbs-2008-ie-update-kb963027-breaks.html. If anyone found a solution for this, please post it. I will open a new thread for that issue, and go ahead and close this one.















0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

This guide is intended to provide step by step instructions on how to migrate from Small Business Server 2003 to Small Business Server 2011. NOTE: This guide has been written using the preview version of SBS2011 therefore some of the screens may …
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now