Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Remote Desktop connection (RDC) Stopped working and I can't get it to work again

Posted on 2009-05-11
8
Medium Priority
?
278 Views
Last Modified: 2013-11-21
I have a windows XP PRO PC that was using RDC without any problems for many years and then recently  the PC got infected with a couple of adware programs that have been removed and since then I cannot connect remotely to this PC no matter what I try.
I had some problems with uninstalling some programs while taking care of the infection and eventually had to remove and re-install ".net framework 1.1 through 3.5" and Windows live Onecare.
So since the PC has been clean it's a NO GO for RDC on the PC.

I've changed RDP port numbers, checked the firewall settings, I've even tried connecting to it using telnet but something is keeping me from connection to it.
I do get a reply when I ping the PC and I can connect from the PC to other PCs using RDC.
I already have the usual configured (ie. added the users under the remote tab in system , allowed remote connections to the PC, etc.) as I mentioned the connection worked perfectly for years.
I've looked for answers but have had no luck.
Any help would be greatly apreciated.
Thank you in advance.

Seb
0
Comment
Question by:1pcxpert
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 

Expert Comment

by:panky23
ID: 24360275
Can you please verify if  all services set to "Automatic" are running? if not which services are failing to run?
0
 
LVL 2

Expert Comment

by:iamshaked
ID: 24361146
First off youve change the RDP ports?
You must change your router settings and port forward the ports to your ip address of the pc you are trying to remote in to.
Default is 3389. please port forward that to your pc's ip address.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:1pcxpert
ID: 24365577
Hello all,
Thanks for the quick reply.

panky23-- yes, terminal services service is set to auto what other services should I be looking at?

Manoj_a-- I'll take a look at the article and will give it a try.

iamshaked-- it's not a port forward issue , when I changed the ports I also configured them accordingly on the router/firewall. Originally when it was working (3 plus years) i had the default port changed to 8787 and the proper config. on the router/firewall. The issue started without any changes done to the router but to troubleshoot I reverted the port back to the default 3389 and made the proper changes on the router/firewall as well and i still cannot connect.

Thanks guys.
Seb


0
 

Author Comment

by:1pcxpert
ID: 24365650
Hello Manoj_a,

I looked at the link you provided and I've already determined that I cannot telnet to this PC so it doesn't help me.
Thanks for trying.

Seb

0
 
LVL 2

Expert Comment

by:iamshaked
ID: 24375670
Do you possibly have a nvidia video card? ive seen some drivers from nvidia that did not allow me to use rdp at all. Might want to look into that.
Is there any software that you can think of that would block ports or something
Windows live Onecare?? check there, spyware doctor if you have that, or possibly look into windows firewall if you havent yet.
0
 

Author Comment

by:1pcxpert
ID: 24376053
Hello  iamshaked,
Not sure on the video card but I'll check.
no new software has been installed so no issue there and I've already checked the windows live one care (removed it and reinstalled it as well) to see if it's configured properly.
no other spyware software installed other than liveonecare.
Windows FW is disabled due to liveonecare but I checked and no issue there.

Thanks for the hints.
Seb
0
 

Accepted Solution

by:
1pcxpert earned 0 total points
ID: 24604973
Hello all,
Resolved the issue by removing the port forward on the router/firewall and reconfiguring it again as well as on the Client PC.
Once that was done things went back to normal.
Thanks.

Seb
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If your system is showing symptoms of browser hijacks or 'google search redirects' check out my other article (http://rdsrc.us/u3GP7A) first and run the tool TDSSKiller (http://rdsrc.us/GDBBs4) to get rid of the infection. Once done, and if the …
Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question