Could not load type (ProfileProvider)

Experts,

I have written a custom profile provider but cannot get it to load.

The failure occurs on line 57 of the web.config file which declares the type (type="ParadoxProfileProvider.SllParadoxProvider").

I have carefully followed the Namespace.ClassName sequence that should be given in the type.

I have tried adding the class code to the "App_Code" section of the WebFile, and several variations of the type, including MyApp.Namespace.Classname, etc. but nothing seems to work.

What am I missing?

Capt
<!--Membership Provider Configuration-->
    <membership defaultProvider="SllParadoxProvider" userIsOnlineTimeWindow="15">
      <providers>
        <clear/>
        <add
		name="SllParadoxProvider"
		type="System.Web.Security.SqlMembershipProvider"
		connectionStringName="cnnParadox"
		applicationName="SLL"
               enablePasswordRetrieval="false"
               enablePasswordReset="false"
              requiresQuestionAndAnswer="false"
              requiresUniqueEmail="false"
              passwordFormat="Hashed"
	/>
      </providers>
    </membership>
    <!--Membership Provider Configuration-->
    
    <!--Profile Provider Configuration-->
    <profile enabled="true" defaultProvider="SllParadoxProvider" >
      <providers>
        <add
		name="SllParadoxProvider"
		type="ParadoxProfileProvider.SllParadoxProvider"
		connectionStringName="cnnParadox"
		applicationName="SLL"
	/>
      </providers>

Open in new window

Glen GibbOwnerAsked:
Who is Participating?
 
Glen GibbOwnerAuthor Commented:
I solved the problem!

Somehow the code was actually invisible to the website when added as a project.

  I re-added the Membership and Profile providers to the App_Code folder of the website (through the "Add Item" menu), where they both loaded as they should.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.