?
Solved

Error Code: 500 Internal Server Error. The target principal name is incorrect. (-2146893022)

Posted on 2009-05-12
3
Medium Priority
?
2,842 Views
Last Modified: 2012-05-06
We have an SBS 2003 Standard R2 environment with ISA Server 2006 Standard on a separate Windows Server 2003 machine (Dual NICs). We cannot figure out how to publish OWA or any other SSL encrypted site hosted on the SBS machine. I have been through everything I can think of and all I get is the error in the question title. Currently the web listener has the 3rd party SSL certificate from Thawte and the web server has a self-signed certificate created using the CEICW. The ISA server is a Domain Member. What am I missing?
0
Comment
Question by:dsasc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 35

Accepted Solution

by:
Bembi earned 750 total points
ID: 24362879
So, fist at all, you have two certificated, one between the client and the ISA, and a second between the ISA and your web server. The certificates must fit to the accessed domain to be valid. So the certificate for the client must be issued for your external domain name, whcih is used to connect to OWA, and the internal certificate must fit to the server name, which is used in ISA to connect to the Web-Server. Or you may decide to leave the internal communication unencrypted.

Read this:
http://www.isaserver.org/tutorials/error505.html 
0
 
LVL 8

Assisted Solution

by:kain21
kain21 earned 750 total points
ID: 24364335
Just to add a little more this, I'm guessing you likely have the "Forward original host header instead of the site name" check box enabled on the To tab of the rule publishing OWA.  If so, you should uncheck this box as the internal site name is different than the external one.  Something else you will need to verify is that the ISA server computer does not receive any certificate errors when it browses via SSL to the internal site name of OWA.  Since you have a self-signed cert, you may need to import the certificate you created with the CEICW into the Trusted Root Certification Authorities on your ISA Server to get rid of any certificate warnings.

Mike
0
 

Author Closing Comment

by:dsasc
ID: 31580457
I resolved this problem with a call to Microsoft support. Both suggestions were used in the resolution for this issue.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

ISA Server detected routes through the network adapter LAN that do not correlate with the network to which this network adapter belongs What does this mean and how can one go about correcting it? In simple terms, this error message indicates t…
In all versions of ISA Server and the current version of FTMG, the default https protocol uses TCP port 443 and 563 only. This cannot be changed within the ISA or FTMG GUI and must be completed from a Windows cmd prompt on the ISA Server itself. …
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question