Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 258
  • Last Modified:

OWA 2007 forms issue

Hi there
Not sure what has happened, but I no longer get form-based authentication. Instead I get the windows logon box.
I am runing Exchange 2007 SP1 CAS role on a Windows 2008 server with IIS 7. I need assistance to check where it has gone wrong.

Jafar54
0
jafar54
Asked:
jafar54
1 Solution
 
MesthaCommented:
There is very little that can go wrong.
FBA is either on or off, but is only available when using SSL.

You could turn it off then run IISRESET and turn it back on again. That will sometimes make it appear again.

Simon.
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Go to Sevrer Config -> Client Aceess -> OWA -.Properties. second tab and see whether FBA is selected.
0
 
jafar54Author Commented:
what are the defualt authentication methods for the OWA virt dir in IIS 7? I have just basic enabled.

I have tried turning it off in the Exchange console and turning it on, but no change.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
aletjollyCommented:
If in case form-based authentication is selected at the following location:
Sevrer Config -> Client Aceess -> OWA -.Properties. second tab

Try diabling the form-based authentication, restarting IIS and then re-enable the form-based authentication at the above specified location and then again restart IIS and try browsing OWA
0
 
jafar54Author Commented:
i still get the windows logon box instead of the form
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Do you have more than one cas server?
0
 
jafar54Author Commented:
no.... 1 CAS and 1 Maibox / Hub Trnasport
0
 
Debug-ExchangeCommented:
please try this
command ##     Remove-OwaVirtualDirectory "owa (default web site)"
command ##     New-OwaVirtualDirectory -name "owa" -OwaVersion Exchange2007 WebSiteName "Default Web Site"

Thanks,
Sam
0
 
jafar54Author Commented:
worked ....thanks
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now