Solved

Unable to install PS4.5 - Installation ended prematurely, error 10001

Posted on 2009-05-12
10
3,265 Views
Last Modified: 2012-05-06
I have a problem installing Citrix PS4.5. All machines are up to date with Windows and have rollup pack 2. Here's what's happening:

Recently the Citrix datastore was moved from SQL 2000 to another server running SQL 2005.
The move was done by copying the database over to the new server and running dsmaint.
The move appears to have been successful for all the existing servers  everything is working.

I came to add a new server to the farm and the installation of PS ends with Installation ended prematurely because of an error Then Error 10001. Ive looked in the KB for the error but none of the solutions/causes fit. I went back to the last test server I built (before the move) and removed PS and tried to reinstall with the same result. Is this likely to have something to do with the SQL move? Any suggestions? The ODBC connection tested OK. I have the install log, but cant see anything obvious in there. Not sure where to go from here& Thanks.
0
Comment
Question by:BenBispham1
  • 6
  • 4
10 Comments
 
LVL 12

Expert Comment

by:Daniel Borger
ID: 24364130
Is there more to the error? Can you get through the install by creating a new Access farm and then join it to the SQl farm?
Is there a chance the installation media is corrupt?
0
 

Author Comment

by:BenBispham1
ID: 24365383
Thanks for the thoughts. There isnt any more to the error, but I do have the MSI log if that would help. Saw this in the event log, dont know if its connected:

Event Type:      Warning
Event Source:      WinMgmt
Event Category:      None
Event ID:      5603
Date:            12/05/2009
Time:            14:47:09
User:            NT AUTHORITY\SYSTEM
Computer:      VCTX01
Description:
A provider, MgmtEventProv, has been registered in the WMI namespace, Root\Citrix\Management, but did not specify the HostingModel property.  This provider will be run using the LocalSystem account.  This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests.  Ensure that provider has been reviewed for security behavior and update the HostingModel property of the provider registration to an account with the least privileges possible for the required functionality.  

Ive done the install again, this time pointing at the old database and the problem is still there. Probably no point trying a new database. Agree?
It seems that this isnt to do with the move. The only thing I can think of that has changed recently would be installation of windows security patches, perhaps one of those has broken something&
0
 
LVL 12

Expert Comment

by:Daniel Borger
ID: 24365581
This looks like a ODBC or SQl username/password issue. To test, try doing an install and choosing a new farm with a local access database. once it's done you can user the chfarm command and add it to the production farm.
0
 

Author Comment

by:BenBispham1
ID: 24373022
I restored the VM to its orginal state and tried the install again with a new farm and local Access DB. I got the same error.

I really can't think of anything else that could have changed...
0
 
LVL 12

Expert Comment

by:Daniel Borger
ID: 24374340
Is there anything else running on the server?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 12

Expert Comment

by:Daniel Borger
ID: 24374363
Are you at the console doing the install and not through RDP?
0
 
LVL 12

Expert Comment

by:Daniel Borger
ID: 24374423
0
 

Author Comment

by:BenBispham1
ID: 24375103
I'm doing the install via RDP as I always have in the past. Is that a bad idea?

Have read both of the articles, I've tried skipping the adding remote desktop users part.
Need to make another install log as I lost it when I reset the VM...

Nothing else running, just clean 2003 R2 SP2. No AV, nothing else.
0
 
LVL 12

Expert Comment

by:Daniel Borger
ID: 24557796
check to see if you have this enabled on your policy.
printer.bmp
0
 

Accepted Solution

by:
BenBispham1 earned 0 total points
ID: 26111908
The problem was caused by a gpo changing permissions on the windows tasks folder, preventing the install from creating a task and causing it to fail.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Citrix XenDesktop 7.6 Citrix Policies Audio
Citrix XenDesktop 7.6 Citrix Policies Graphics
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now