Solved

Multisite issues with .com urls Post installation " Drupal 6.x

Posted on 2009-05-12
6
461 Views
Last Modified: 2012-05-06
I recently installed Drupal on my webserver.  When I create a new site (via the Drupal interface) it creates the site in IIS as "website.com".  When I try to access the folder website.com/drupal/sites/website.com/ it gives me this error message:

You are not authorized to view this page You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server.

Please try the following:

* Contact the Web site administrator if you believe you should be able to view this directory or page.
* Click the Refresh button to try again with different credentials.

HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource.
Internet Information Services (IIS)

IIS is trying to serve the .com as the filetype .com which triggers a username/password prompt and then the above error message.

Its not folder permission issue, as I can rename the folder to anything not .com and it works (.org, .net, etc) but then drupal breaks for the website...

Note: this is not a drupal specific issue, though using multisite with drupal is the only time I'd need to name a folder "something.com".

Is there a way I can modify Drupal's code so it doesn't require the .com?
Eg: website.com/drupal/sites/website/files

Or fix IIS?
0
Comment
Question by:ddotson
  • 3
  • 2
6 Comments
 
LVL 37

Accepted Solution

by:
meverest earned 350 total points
ID: 24371049
Hi,

probably the 'drupal/sites/...' path does not have the correct access rights applied.

find that target location in windows explorer, right click the 'sites' folder, choose security and give read/execute rights to the interactive web user (i.e. IUSR_<servername>) or to 'everyone' user if you don't care about who gets access.

Cheers.
0
 

Author Comment

by:ddotson
ID: 24395109
Sorry for the delay in getting back to you...

I've checked these permissions and they appear to be correct.
0
 

Author Comment

by:ddotson
ID: 24445154
Do you have any other suggestions?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 37

Expert Comment

by:meverest
ID: 24446518
try adding a mime type for .com to something like "text/html"

Cheers.
0
 
LVL 3

Assisted Solution

by:Anybody13
Anybody13 earned 150 total points
ID: 24582251
Hello,

do I understand you right?

Without .com your Server doesn't make any problems anymore, but if you delete the .com your drupal doesn't work anymore, because you've installed it with the other directory-name?

If I am right with this, have a look at your settings.php and check, if the folder is set there (delete the .com than) and search all your database-tables for the phrase "website.com" and replace it with "website".

After that change it should work, because drupal now thinks you've installed it into the folder "website" correctly.
0
 

Author Comment

by:ddotson
ID: 24696738
Unfortunately,  I am not longer able to work on this issue.  Points awarded for participation.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is for those that are having major problems with users upload files such as pictures to their profile. The solution is simple and has to do with correcting the directory paths. With some experimenting and testing i got it fixed. Note…
First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) (http://technet.microsoft.com/en-us/library/cc758834(WS.10).aspx) is a much better solution when you need to p…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now