[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4582
  • Last Modified:

VNC Port forwarding for Verizon Fios Westell 9100 EM

I have been using ultravnc for a long time now and have never had issues setting up port forwarding for any of my routers.  (Linksys, Netgear, DLink).   I just switched from TW to Fios and they installed a Westell 9100 EM router.  I setup the Port Forwarding but it still won't pass the connection through.  If I put the computer on the DMZ it works.  This tells me I have the right wan port and the computer is accepting the connections, I just don't have something configured properly.

Below is a copy of the port forwarding.

Local Host      Local Address    Network Address      Public IP Address   Protocols

localhost       127.0.0.1           Any                  Any             TCP Any -> 4567
192.168.1.100   192.168.1.100    Verizon FIOS Service     Any            0000007231485188 - UDP Any -> 63146
"Computername"  "ComputerName"           Any                 Any            VNC - TCP 5800 -> 5800
                                                                         TCP 5900 -> 5900
                                                                         UDP 5800 -> 5800
                                                                         UDP 5900 -> 5900 Active
0
GoneFishing65
Asked:
GoneFishing65
  • 7
  • 6
1 Solution
 
lanboyoCommented:
If you are going to a pc, the main port you need to forward is tcp 5900. tcp 5800 is for java, and the udp ports are unused.


Does computername resolve to the IP that you have the pc set up on? Is it outside of the dhcp ip range?
0
 
GoneFishing65Author Commented:
When I said I know I have the right wan port, I meant WAN IP.

Yes, the computername does resolve the correct IP.  The first time I had this setup with a Static IP outside of the DHCP pool and read somewhere it may cause the problem.  I then put the computer back on DHCP and used computername to resolve to the proper IP and that still didn't work.

0
 
lanboyoCommented:
I am unfamiliar with how these routers work, I am basing most of this on other models. I don't understand how the router keeps track of the pc in order to send the packet to the right internal pc.
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
GoneFishing65Author Commented:
Just so we don't have to worry about how the router handles the name resolution, I changed it from "Computername" to the actual IP.   I'm sure once I get this to work, I'll be able to get it to work using name resolution.
0
 
lanboyoCommented:
Okay sure. Is the proxy host setting currently disabled? That may take precedence over the individual port forwardings. Also, is the tcp 5900 also currently active or just the tcp 5800 forwarding? In text mode this is confusing.
0
 
GoneFishing65Author Commented:
I've attached the router screen shot.
Yes the TCP port forwards are all active.
Proxy host setting?  Any idea where that is?
Router-Config.JPG
0
 
GoneFishing65Author Commented:
I also turned on the logging for this and attached is what showed up.

71.244.X.X is the Wan port for Verizon.  97.65.X.X is the Wan port from work which is where I am trying to connect from.


firewall.log
0
 
lanboyoCommented:
I'm sorry, I meant , is the DMZ connection still configured and active?  Now I don't know if the DMZ rule is configured like most routers in that all traffic not matched by other port forwarding rules goes to the DMZ, or that it selfishly grabs all tcp ports leaving nothing to get to the other port forwarding rules.

Does the Xbox port forwarding work?  Also, just in case, port 5900 is used when the server is listening on desktop :0  if you are sharing a different desktop the port number goes up by 1 for each desktop. Linux boxes are usually on tcp 5901 for :1 , 5902 for :2 ,etc.
0
 
GoneFishing65Author Commented:
DMZ is turned off.
I assume the XBOX forwarding works.  The weird thing is I didn't add that.  I think it did automatically when I setup my XBox on the wireless.
Desktop is listening on 5900.  I have not changed the listening port.
0
 
lanboyoCommented:
Okay this is the last thing I have... Forward tcp 5500 to the vnc box as well. Some documentation claims this is neccessary, although I have never needed it.
0
 
GoneFishing65Author Commented:
Added 5500 and that didn't work either.
0
 
lanboyoCommented:
I admit that I am stumped. Does the PC still have the same IP?
0
 
GoneFishing65Author Commented:
I figured it out last night.  Not sure why it works, but it works.
If you look at the screen shot above where it says TCP 5800-> 5800 and 5900 -> 5900
It should read TCP ANY -> 5800 and  ANY-> 5900.

I had always thought and done with all the previous routers you had to specifiy the port on both sides.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now