Solved

Adding usbserial to fresh Ubuntu install

Posted on 2009-05-12
3
1,213 Views
Last Modified: 2013-12-15
I'm trying to install a Sierra Wireless (Sprint) air card to a Dell laptop.

The instructions say that the usbserial module should be installed by default, but it is not.  

How do I install that off the CD?  I can't get online until I can get the aircard up and running.

Thanks!
0
Comment
Question by:Jared Luker
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 16

Accepted Solution

by:
ai_ja_nai earned 400 total points
ID: 24372545
Maybe it's there, but it's not loaded.

With the device plugged run dmesg. You should see something like

usb 1-1: new full speed USB device using uhci_and address 2
usb 1-1: configuration #1 chosen from 1 choice

Unplug the device and run lsusb; take note of the output.
Plug the device and run lsusb again: there should be one more line, comparing to the precedent output (something like Bus 001 Device 002: ID 4348:5523). Take note of this line.

Now issue sudo modprobe usbserial vendor=0×4348 product=0×5523. Note that the number are the same of the ID you jotted down before.


Run dmesg again and you shall see lines similar like this :

usbserial_generic 1-1:1.0: generic converter detected
usb 1-1: generic converter now attached to ttyUSB0
usbcore: registered new interface driver usbserial_generic

As you can see, the new serial port device is mapped to /dev/ttyUSB0. You can instruct Ubuntu to load this module automatically by include the line : usbserial vendor=0×4348 product=0×55233 inside /etc/modules file.
0
 
LVL 4

Assisted Solution

by:amrox
amrox earned 100 total points
ID: 24387364
You can also see if its loaded by running lsmod
eg: lsmod | grep usbserial
Output should be something like
usbserial  45296  4  option
If its not listed then it's not loaded.
on my ubuntu box the module lives in /lib/modules/2.6.28-generic/kernel/drivers/usb/serial/usbserial.ko

Find it with find or locate, and insert into kernel with insmod.  But my guess is you already have it loaded.
0
 
LVL 17

Author Closing Comment

by:Jared Luker
ID: 31580721
Thanks... it's working.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question