• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 731
  • Last Modified:

winexit.scr gives a registry error

Hello,

I am having the same problem as in this thread:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_21118936.html?sfQueryTermInfo=1+10+exampl+winexit.scr

I am getting this error instead of it closing programs and logging out:
"Error encountered while creating registry key. Make sure you have Set Value and Create Subkey permissions."

Can anyone tell me 1) what registry keys is this reffering to and why; and 2) how to fix this without changing user rights which I cannot do in our environment.

I tried the link given in the solution but it no longer works.

We are running windows 2000 sp4 and XP sp2 on the workstations, and win 2k and 2003 on the servers, with latest service packs.

Thanks,

maureen
0
maureen99
Asked:
maureen99
  • 3
  • 2
1 Solution
 
maureen99Author Commented:
Arrgh....I can't open regedt32.exe, it opens regedit.exe instead.  Tried to rename regedit.exe to regedit.xxx to see if i could open regedt32.exe and got access denied.  Why won't uncle bill let me

do what I want with my own computer?  I am really tired of windows trying to protect me from myself!!@  /rant off

After a reboot I did manage to rename regedit.exe in c:\windows system but it still opens when I open c:\windows\system32\Regedt32.exe. there a way around this?

thanks again!
0
 
jcimarronCommented:
maureen99--Why are you playing with regedt32.exe?  That first link I gave you says
"In Windows XP and later, Regedit.exe is the only Registry Editor tool that is included in the operating system. Regedt32.exe is no longer a part of Windows XP or Windows Server 2003. "  It is correct that if you try to run Regedt32.exe, you will open Registry Editor which is regedit.exe.
0
 
jcimarronCommented:
0
 
maureen99Author Commented:
That's ok...I figured out how to change the permissions by right clicking on the HKEY_Local_Machine\Software\Microsoft\Windows NT\CurrentVersion\IniFileMappings\Control.ini key and going into the permissios.  This fixed the original error.

BTW, my earlier rant was directed at MS no you.  Your links have helped me fix the original problem.

thanks very much for your help!

Maureen
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now