Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Installing xServer

Posted on 2009-05-12
11
Medium Priority
?
1,071 Views
Last Modified: 2012-06-27
Im trying to run starx command on Linux Fedora 10, but it does not work properly, I guess I need to install Xserver but I do not know how, or maybe I just need to configure something.
[root@servidor bin]# DISPLAY=:0.0
[root@servidor bin]# startx
hostname: Unknown host
xauth:  creating new authority file /root/.serverauth.3326
 
 
Fatal server error:
Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.
 
Invalid MIT-MAGIC-COOKIE-1 keygiving up.
xinit:  Resource temporarily unavailable (errno 11):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.
[root@servidor bin]#

Open in new window

0
Comment
Question by:latorreconsultores
  • 5
  • 4
  • 2
11 Comments
 
LVL 81

Expert Comment

by:arnold
ID: 24370915
When setting display it should be DISPLAY=localhost:0.0.  If you are in a graphical session, the DISPLAY variable should be set for you.

Check /etc/inittab and see what startlevel you have. 3 or 5 (5 is graphical).

When you loged into the system did you have a graphical login, or a text based?  Did you select a failsafe session or a graphical kde, gnome, etc.?
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24370927
Hi,

It says:

Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.
 
It seems that X server is already active try to access using pressing <ALT> + <F7> from the console. X is for console only you can not activate it through a remote connection unless you have a client like VNC or an X Server like CygWIN.

Cheers,
K.

0
 
LVL 2

Author Comment

by:latorreconsultores
ID: 24370930
arnold:
when I start the session, starts on graphic mode, I set hostname as:

hostname myhost                      -- so I set the DISPLAY variable as
DISPLAY = myhost:0.0               -- but the result is the same

/etc/inittab                                  -- has set on 5 level
                                                    -- gnome is the enviroment, Fedora 10 my OS.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 2

Author Comment

by:latorreconsultores
ID: 24370949
KeremE:

In fact Im on a graphic mode, I open a text terminal and I try to run startx command but it does not work properly.

what do I need to do to run it?
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24371016
:) If you are in Graphic mode = You're already running X !

You can't run a second instance. What is your purpose on starting X ?
0
 
LVL 2

Author Comment

by:latorreconsultores
ID: 24371037
KeremE:

The problem is that I wanna install some software that needs to open a Xterminal, but it does not work, I try to open another terminal on another Linux Suse, and works fine.



that is the problem.
0
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 200 total points
ID: 24371083
@ latorreconsultores:
> KeremE:

> The problem is that I wanna install some software that needs to open a Xterminal, but it does not work, I >  try to open another terminal on another Linux Suse, and works fine.


> that is the problem.

Not really. Since you're currently running in X you don't need to open another X terminal. When you run any application from a text terminal will launch from your X session. You don't need no more X sessions.
0
 
LVL 81

Expert Comment

by:arnold
ID: 24374278
Agree with KeremE.
While in the terminal session.  Do not redefine DISPLAY.
Run the install of your application and it should open the graphical interface for the install.  Alternatively, use the file manager to navigate to where the application is and start the install directly without going through the terminal.

If the purpose of the terminal is so that you can elevate your privileges. i.e. loged in as usera with limited access and then you sudo or su to gain root rights, you might not need to go through that process.  When you start the installer from file manager, you might get prompted for credentials to elevate the rights.
If sudo is your only option.
you should prior to running sudo, add localhost to the X server with xhost +localhost.
after you sudo you should be fine.
The Xserver event though it is running under usera localhost:0.0 will not accepted root X server windows unless usera adds localhost to the allowed hosts rule with xhost.
0
 
LVL 2

Author Comment

by:latorreconsultores
ID: 24375383
keremE
arnorld:

thanks 4 ur comments, Im going to try to install from the file manager insted a terminal.
Im gonna contact you to tell you the result.

have a nice day
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24375457
Take your time let us know when you need help :)
0
 
LVL 2

Author Closing Comment

by:latorreconsultores
ID: 31580817
The solution was easy to understand and it was accurate. Thanks.
LaTorre
0

Featured Post

Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can use conditional statements using Python.
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month13 days, 11 hours left to enroll

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question