Solved

WSS 3.0 on SBS2003 event 2436 error after install WSS SP3

Posted on 2009-05-12
24
1,288 Views
Last Modified: 2012-05-06
After installing SP3 for WSS 3.0 the search function no longer returned results and the 2436 errors started. The event log (sans server and DB name) follows, but I have tried the following:
Changing accounts under search service for content and search per (http://support.microsoft.com/default.aspx?scid=kb;en-us;927012) to read enabled users (same and different) for the content and search databases. Restarting the the service. Stopping and creating a new search database. Not to mention about 4 or 5 (blocked items, etc.) other suggested changes including AAM. So what do I try next? I can't help, but think this is something related to SP3 as it had been working some time (1+ years) and the installation is per MS recommendations for a parallel install of WSS 2 and 3 on SBS2003.

Event Type:      Warning
Event Source:      Windows SharePoint Services 3 Search
Event Category:      Gatherer
Event ID:      2436
Date:            5/12/2009
Time:            6:10:03 PM
User:            N/A
Computer:      XXXXXXX
Description:
The start address <sts3://XXXXX:1730/contentdbid={60864f21-6eda-4db0-a7fc-052c5797fedc}> cannot be crawled.

Context: Application 'Search index file on the search server', Catalog 'Search'

Details:
      The object was not found.   (0x80041201)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
Comment
Question by:pj_reid
  • 12
  • 6
  • 3
  • +1
24 Comments
 
LVL 51

Expert Comment

by:tedbilly
ID: 24381728
Have you tried setting the DisableLoopbackCheck in the registry?  Some recent updates from Microsoft are enforcing a rule to block loopback's on the same server which raises problems with Sharepoint.
0
 

Author Comment

by:pj_reid
ID: 24392408
Thanks - I tried that along with another related MS KB. Good thought though.
0
 
LVL 51

Expert Comment

by:tedbilly
ID: 24392508
The reason I recommended that setting is the sts3 syntax is using the Sharepoint Web Service to execute the search.  This article talks extensively about the topic:
http://social.technet.microsoft.com/Forums/en-US/sharepointsearch/thread/2b760f44-3eed-4ab0-96fb-fdccffe0cfdd

So, we have to determine what the crawler or indexing account can't access the web service.
0
 

Author Comment

by:pj_reid
ID: 24428700
Okay what would suggest next? I read the article, but I don't exactly see what to look at next.
0
 
LVL 51

Expert Comment

by:tedbilly
ID: 24435452
Check your content scope, maybe we could try changing it to do a http search instead.
0
 

Author Comment

by:pj_reid
ID: 24437701
I'm knowledgable to the point of being dangerous. How do I check and/or change the content scope?
0
 
LVL 51

Expert Comment

by:tedbilly
ID: 24437743
In the search administration there is an option to set 'Content Sources' (sorry I gave you the wrong term)  If you look closely one will be set for the site you are searching.  In the options you can change the starting URL for the search.
0
 

Author Comment

by:pj_reid
ID: 24437762
Yes - I check that. It matches the site I want to search.
0
 
LVL 51

Expert Comment

by:tedbilly
ID: 24437804
What are the settings for it?  Can you list them here?
0
 

Author Comment

by:pj_reid
ID: 24458381
Sorry for being slow. What do you mean by setting?
0
 

Author Comment

by:pj_reid
ID: 24458565
Are you refering to content databases under application management or sevices under operations on the WSS 3.0 central admin panel?
 
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 51

Expert Comment

by:tedbilly
ID: 24460282
No I mean the content source settings.  You have to edit the content source to see them.
0
 

Author Comment

by:pj_reid
ID: 24461692
Database server  
 HHVHSRV1\Microsoft##SSEE  
 
SQL Server database name  
 WSS_content  

Database status  
  Ready
 
Database authentication  
 Windows authentication  
 
Search Server  is HHVHSRV1
 
 the URL for the site HHVHSRV1:1730

This is an internal sharepoint. I have no external facing sites, FTP, etc.
0
 
LVL 2

Expert Comment

by:kaustic
ID: 24541998
I had the same error after installing Service Pack 2 for MOSS. It was Windows SharePoint Services Search.

Here's how I resolved/worked around:

1) Find the offending Database. Use Management Studio "Select name from <configDB>.dbo.objects where id ='<error guid>'". Yours should look like "Select name from Sharepoint_Config.dbo.objects where id ='60864f21-6eda-4db0-a7fc-052c5797fedc'"

2) In your case it looks like it's on a different port, so probably not a main content db. For me it was the SSP content db and I really didn't need to index anything on that site.

I went to Application Management --> Content Databases --> Choose the Web Application with the offending database --> Select the database

Under Search Server if you have a search server selected like "HHVHSRV1"  change it to "Select one..." and hit OK.

Basically I didn't need the content from that site indexed so I excluded it from being acknowledged by the search server and thus it didn't reach out for it creating the error.

I was close to stopping the Windows SharePoint Services Search serivce in Operations. That would delete everything related to that service and you would need to re-config. It may be your best bet if you can suffer some down time and need that content indexed.

Hopefully some options :)
0
 

Author Comment

by:pj_reid
ID: 24543821
This is on a SBS2003 server which has side by side WSS 2.0 and 3.0 databases. This is required as SBS2003 is tightly integrated with WSS 2.0 and removing same is not wise or recommended. In any case I do want it indexed as it is our primary content database. Oddly enough. The original companyweb is in place to make SBS happy and provide the original featrues and services it provides.

I ran into this problem when I first setup the side by side install. I eventually deleted and recreated the WSS 3.0 database and the search started working. At this point that really isn't an option. I suppose I could create another content database and see if it can be found. Sadly this started when I approved a WSS SP inadvertently. I know better than to do that before researching the issues and work arounds to the SPs.

Thanks for the options:)
0
 

Author Comment

by:pj_reid
ID: 25213029
Sorry to say the problem still exists. I may be forced to delete the site and recreate it:(....the last thing I wanted to do and the primary reason why I posted on this site.
0
 
LVL 38

Expert Comment

by:Philip Elder
ID: 25347652
0
 

Author Comment

by:pj_reid
ID: 25362674
I tried something similar to the links, but I'll try again.

Thanks,
-peter
0
 

Author Comment

by:pj_reid
ID: 25377776
I tried the solutions provided by MPEC Sinc and it still doesn't work.  I think I might cancel my subscription to this service as it has not proved to be as helpful as I hoped. Like I said I'm 0 for 2 now. Thanks for your help,
Peter
0
 
LVL 38

Accepted Solution

by:
Philip Elder earned 500 total points
ID: 25380342
0
 
LVL 38

Expert Comment

by:Philip Elder
ID: 25382906
Kewl! :)

Philip
0
 

Author Comment

by:pj_reid
ID: 25389414
Thanks again.  There isn't a good reason why the solution works, but it does.

-peter
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

This article is in response to a question (http://www.experts-exchange.com/Networking/Network_Management/Network_Analysis/Q_28230497.html) here at Experts Exchange. The Original Poster (OP) requires a utility that will accept a list of IP addresses …
Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now