I have tried all of the above, no help.

IE6 on Windows 2000 - with GoogleBar.
The Google search field is disabled, I can not type in it.
The IE Help Menu "About Internet Explorer" gives : "An error has occurred in this dialog - Error 96 - Unspecified error".

I tried to IEFix, it asked for the Windows 2000 CD, and reinstalled IE (I guess).
Then I restored the default settings.
Then I registered mshtml.dll and jscript.dll, the other mshtmled.dll failed because the dll does not seem to be present.
angelastroAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Wardy_01Connect With a Mentor Commented:
if the install option isn't in te list for some reason you might want to try this ...


BE WARNED THIS INVOLVES EDITING THE REGISTRY SO GO VERY CAREFUL !!!

1.      Click on the Start button and then click on the Run option.
2.      In the Open field type regedit and press the OK button.
3.      Navigate to the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{89820200-ECBD-11cf-8B85-00AA005B4383}
4.      Under that key you will see a entry named IsInstalled. Right click on that entry and left click on Modify.
5.      Change the Value from 1 to 0.
6.      Exit regedit.

Now you should be able to to an install as if IE isn't even on the machine.
You just need an IE6 setup executable ....

30 seconds on google should pull one of those out :)
0
 
geowrianCommented:
Probably not the best answer out there, but you could upgrade/downgrade your IE browser, reboot, then upgrade/downgrade back. I've seen that fix corruption and bad default settings.
0
 
Wardy_01Commented:
Permissions maybe ?

IE Runs under the context of the current windows user I think, maybe it uses some resource that your account does not have permission to, try adding your account (if you haven't already) to the administrators group on the machine.

If not ...
It sounds like there might be some corruption in the install (the about dialog ... suspicious).

Try downloading the IE setup files for IE7 online and set that up instead or is it vital that you run IE6 on the machine ?

0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
geowrianCommented:
Nevermind...I noticed the Windows 2000 in the question. IE7 doesn't exist for Windows 2000. You could try downgrading the browser to IE 5.5 and then back up to 6.
0
 
angelastroAuthor Commented:
Indeed, notice the Windows 2000.
And that the PC is being used for years, normal office use, no development, and that this problem now suddenly comes up since a few days, without anything having occurred related to it that I am aware of.
(Permission always has been administrator)

Is the only way to force a re-install of IE6 really to downgrade to 5.5 (horror) ?
0
 
geowrianCommented:
Sometimes stuff like this happens with PCs. Improper shutdowns, viruses, failing hardware, system changes, etc. could also be a culprit.

You could try these steps, but I haven't done them myself to confirm: http://www.theeldergeek.com/repair_reinstall_ie_and_oe_6.htm
0
 
Wardy_01Commented:
I'd put this down to an upgrade / patching issue and do a rollback on the server.

Failing that your only option is to try and repair / reinstall using geo's link.
0
 
angelastroAuthor Commented:
Method 1 of theElderGeek (sfc /scannow), was already implictly run by IEFix.
Anyhow, I did it over : no result.

Before going to his method 2 (enabling reinstalling IE6 by tweeking the register), I looked into SYSTEM32. There, mshtmled.dll was indeed missing.
Now, interestingly I also use the IE editor myself in my own applications, and they indeed do not run anymore on this particular PC.
So I first naively copied mshtmled.dll from the DLLCACHE to SYSTEM32, and registered it successfully : no result to the problem of typing into IE input fields.

Now thinking it over.
(sigh)
0
 
Wardy_01Commented:

Might be worth looking at any other dependencies that IE might be missing or the dependencies of the DLL you just copied.

Sounds like something vitally important is missing somehow ... not a versioning issue is it ?
0
 
angelastroAuthor Commented:
"not a versioning issue is it ?" : would not know how
did not touch IE for as long as I can remember, windows update is OK, sfc is OK
and, "About Internet Explorer" fails, as mentioned above

How to look for other dependencies ?
0
 
Wardy_01Commented:
yeh thats a hard one ...  hmmmm

Since IE 6 is not installed as part of the OS on win 2k you could completely remove and reinstall it but lets start by seeing if it's repairable.

try this ...

1.  go to add/remove programs
2.  find ie6 and double click.
3.  select repair.
4.  follow the on screen instructions.
5.  reboot the machine

This may require the original windows disc, if it does this likely points at the problem being a vital part of the OS that IE relies on is missing.

The wizard should fix it though.
0
 
angelastroAuthor Commented:
WOW:
trying to Add/Remove IE6, a MessageBox pops up :
An unexpected error occurred.
Class not registered
res://appwiz.cpl/listbox.htc
Line 225
I click OK, and then the Add/Remove window says
"No programs installed on this computer",
while the listbox shows a list of icons with no labels, as if it wanted to show the installed programs but fails to show their names.
0
 
Wardy_01Commented:
uh oh ...  That don't sound healthy.
Probably about time the server got a rebuild.

Add/Remove progs should never break, I'm inclined to guess virus or similar at this point but it could just be years of degredation.

If I had gotten this far I would likely stick my windows disc in the drive and run an install over the top of the existing install, in theory that should replace any missing files, it's probably a bit extreme at this point though.

Most of our servers are virtualised so in my particular situation it would n't be that hard , I could basically take 2 actions ....

1. rollback the vm to a recent back up that didn't have the issue
2. deploy a new vm from a template and migrate the important stuff over to it.

Not sure what you should do though, I recommend a rebuild though.
0
 
angelastroAuthor Commented:
OK
trying a fresh install of IE6 first
0
 
angelastroAuthor Commented:
Wardy_01 :
fresh installed IE6 after tweeking "IsInstalled" -> result : IE6 is healthy again
Thx

Now still Add/Remove program problem left. Looking into it. Google shows I am not the first one with this problem :(
0
 
aucklandnzCommented:
try registering the following dll's

regsvr32 mshtmled.dll
regsvr32 jscript.dll
regsvr32 /i mshtml.dll
0
 
angelastroAuthor Commented:
I had tried to register these 3 DLL's at the start of this thread, and mshtmled.dll had failed because it was not in system32 anymore for some reason (see above).

After reinstalling IE6 I registered those again -> no result as Add/Remove Programs is concerned, it still fails.
0
 
angelastroAuthor Commented:
Comparing the registry values with the values they should have according to MS http://support.microsoft.com/?kbid=266668http://support.microsoft.com/?kbid=266668, I notice only 2 differences :

instead of
[HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
 "ThreadingModel"="Apartment"
[HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\ProgID] "ADODB.Recordset.2.5"

my register has
[HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
 "ThreadingModel"="Both"
[HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\ProgID] "ADODB.Recordset.2.8"

Could this explain the problem ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.