Solved

Disk fault in RAID 5

Posted on 2009-05-13
6
1,434 Views
Last Modified: 2013-11-14
System
DELL Poweredge 2950 BIOS rev 1.2.0
Red Hat Ent Linux AS release 4 installed
PE expandable RAID controller ver 5.0.1
HA0 PERC 5/i 5.0.2
4 x 15K 73Gb SAS HD FUJITSU in RAID 5 with one virtual drive defined

One of my disks reported error on the front chasis (E1810 HDD0 fault). When I got into Ctrl R RAID Utility I see disk 0 in red with message fault.
When I tried to enter F10 Utility mode it said "Utility partition not available".
I have a new Fujitsu MAX3073RC disk for replacement.
I have googled and find out that some people had the same error and that wasn't a fault drive.
I need to know what are the proper procedure to find out is that a faulty drive, and if it is, how to replace it and don't loose any data or system.
Do I need to replace disk in BIOS or hot swap while linux is working?
How do I disconnect disk, connect other, and rebuild.
Thanks in advance.
0
Comment
Question by:Kechka
  • 3
  • 3
6 Comments
 
LVL 18

Expert Comment

by:chuckyh
ID: 24374561
Do you have hot swappable drives? I would unplug the faulty drive and replug it back in, then tell the RAID utility to rebuild the volume. Usually the faulty drive will work again if it wasn't truly faulty. If it still says faulty then plug in your replacement drive and rebuild.
0
 
LVL 10

Author Comment

by:Kechka
ID: 24378788
It's a swappable drive, and plug out and plug in did not change the faulty status. When you say to change the drive and rebuild I asked in question do I do that in BIOS or in linux?
0
 
LVL 18

Expert Comment

by:chuckyh
ID: 24378903
Do you have open manage installed in linux? you can manage the raid volumes there.
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 
LVL 10

Author Comment

by:Kechka
ID: 24378952
I don't have open manage installed. I can install if that's the proper way to do rebuilding.
0
 
LVL 18

Expert Comment

by:chuckyh
ID: 24378980
0
 
LVL 10

Accepted Solution

by:
Kechka earned 0 total points
ID: 24482855
So I went to the trip and solve the problem. Since the disk was pulled out for a long time, when I opened the BIOS raid utility there was no fourth disk in the list. When I installed either new or old (reported faulty disk) the utility see the disk but I can add it only as hot spare (yes, the old one also).
I installed OMSA and try to adding disk with hot swap but nothing happened (also only hot spare). I noticed the question mark about firmware and driver version, so I updated the PERC firmware to required version. After that I pluged a old disk and the rebuiding start at once. So the disk was't faulty at all.
I hope that this will help someone...
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Raid 0 2 80
NetApp space reclaim 3 31
can't able to access NAS using my AD credentials 4 43
Error  Dell Equalogics 2 20
Create your own, high-performance VM backup appliance by installing NAKIVO Backup & Replication directly onto a Synology NAS!
The question appears often enough, how do I transfer my data from my old server to the new server while preserving file shares, share permissions, and NTFS permisions.  Here are my tips for handling such a transfer.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question