Solved

Outbound Faxing not Working With Cisco 2800??

Posted on 2009-05-13
18
1,166 Views
Last Modified: 2013-12-27
I have been trying to solve this for months and haven't really gotten far.
I have a SR140 brooktrout ina  server running FACSYS, and incoming fax's are working fine.

the main out bound Dial-peer is :
dial-peer voice 9 pots
 destination-pattern 9T
 progress_ind setup enable 3
 progress_ind alert enable 8
 progress_ind progress enable 8
 direct-inward-dial
 port 0/0/0:15
This works for all our calls on the CCM.
No Fax's outbound worked with this even though they were matching dial-peer

I can get the system to send local (national) fax's Using this Dial-peer and a prefix of 6 :

dial-peer voice 6 pots
 description - National <11 -
 destination-pattern 60[1-2]T
  port 0/0/0:15
 forward-digits 10

Can anyone think of any solution to get this to work with our normal dial-pattern, or a dial pattern I can use for International dialing UK? Anyone know why using a dial-pattern 6T doesn't work?

I have added the  -1 value to the brooktrout t.38 parameters.

Thanks in advance!
Cantana don't have a reply, neither does our Fax Server support staff??


0
Comment
Question by:KS_BHENRY
  • 9
  • 5
  • 4
18 Comments
 
LVL 5

Expert Comment

by:ksims1129
ID: 24373721
When you say not working do you mean not reaching the other end or what?
0
 

Author Comment

by:KS_BHENRY
ID: 24373726
Not reaching the other end, or timing out?
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24373768
can you give me an example UK number as Im from the U.S. not to familiar with the numbers?
0
 

Author Comment

by:KS_BHENRY
ID: 24373785
Dialed from our office with prefix 9
9 0207 123 1234 (national calls)
9 00 44 123 123 1234 (International calls)
0
 

Author Comment

by:KS_BHENRY
ID: 24373848
I think International is
9 00 44 12 1234 1234
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24373869
how do you make a long distance call for instance to someone on the other side of the country
0
 

Author Comment

by:KS_BHENRY
ID: 24373927
That would be national
9 0131 349 1234 (that would call scotland from england)
9 01932 349 1234 (this would call a different county)
To call USA - North Carolina?
9 00 1 919 123 1234
To Call South Africa
9 00 27  31 123 1234

Hope all this helps
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24373979
try adding a new dial peer for faxing dial-peer add

destination-pattern 8T (or whatever you want
port 0/0/0:15
prefix 0131

this will will prefix all of your national calls with
0
 

Author Comment

by:KS_BHENRY
ID: 24374103
wouldn't adding the prefix 0131 would only allow scotish calls ?

All my National calls are working with this dial-peer
dial-peer voice 6 pots
 description - National <11 -
 destination-pattern 60[1-2]T
  port 0/0/0:15
 forward-digits 10

This dial peer matches all local (National) numbers and sends a Fax. I'm trying to figure out an international dial-peer for UK even though the 9T for call manager works fine?? so when I tried 6T direct fax's to the gateway I thought it would work, but it doesn't
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 6

Expert Comment

by:greekstones
ID: 24386538
hi there

can you please send the configuration of your E1 or T1 controller please ,
0
 

Author Comment

by:KS_BHENRY
ID: 24393231
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bchan-number-order ascending
 no cdp enable
0
 
LVL 6

Expert Comment

by:greekstones
ID: 24394181
Ok sorry are you using MGCP can you please upload the router configuration.
0
 

Author Comment

by:KS_BHENRY
ID: 24394196
Using H323

Building configuration...

Current configuration : 5975 bytes
!
! Last configuration change at 08:40:51 UTC Fri May 15 2009 by bhenry
! NVRAM config last updated at 08:40:52 UTC Fri May 15 2009 by bhenry
!
version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname KSGATEWAY
!
boot-start-marker
boot system flash:c2800nm-spservicesk9-mz.124-22.YB.bin
boot-end-marker
!
card type e1 0 1
logging message-counter syslog
logging buffered 51200 warnings
!
no aaa new-model
clock calendar-valid
network-clock-participate wic 0
network-clock-participate wic 1
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name kstrode.co.uk
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
!
!
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
!
!
!
!
voice class h323 1
  h225 timeout tcp establish 3
!
voice class h323 2
  call start fast
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^200/ /4051/ plan any isdn
 rule 2 /^2/ /42/
!
voice translation-rule 9
 rule 1 /^0/ /90/
 rule 2 /^1/ /901/
 rule 3 /^2/ /902/
 rule 4 /^3/ /903/
 rule 5 /^4/ /904/
 rule 6 /^5/ /905/
 rule 7 /^6/ /906/
 rule 8 /^7/ /907/
 rule 9 /^8/ /908/
 rule 10 /^9/ /909/
!
!
voice translation-profile Inbound
 translate calling 2
 translate called 1
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
crypto pki trustpoint TP-self-signed-2855053991
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2855053991
 revocation-check none
 rsakeypair TP-self-signed-2855053991
!
!
crypto pki certificate chain TP-self-signed-2855053991
 certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32383535 30353339 3931301E 170D3037 30393034 31343130
  32365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 38353530
  35333939 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CFD2 6C459E4A 8D2C226F 0101C40C E073185C F8388054 C780E6BF 86BE8740
  E0DEBD42 35101BF1 E34CF60D CEB32998 AF6DDD57 009DB20E EF3AE4BE 0CEE423C
  009232E2 91C6A541 CC7B125F AEAF986F A45A2727 3F5D8E36 3DF5105F 4105574A
  AD4CBE9C 836957D0 A5D4B26F 89FEBD2F 89736455 2A39A2B4 570BDD14 7814AD6E
  B7CF0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 174B5347 41544557 41592E6B 7374726F 64652E63 6F2E756B
  301F0603 551D2304 18301680 141AB7F0 47FE1365 E05E7E0A 16F5470D 688EF604
  5A301D06 03551D0E 04160414 1AB7F047 FE1365E0 5E7E0A16 F5470D68 8EF6045A
  300D0609 2A864886 F70D0101 04050003 81810054 99A28080 E635841A 03F6FF29
  8F273FE9 7ADFCE45 83954BEB 74E04804 5B4F47D2 AD76550F 76E5ECD7 C4292EC0
  CA2E24C8 F47B3E87 8E4CB4A1 B3C42EA5 028B4481 635227F6 FA1DCA5F 2A0C91DC
  EFEE7D4F BF7887E4 0BE37395 9EE5F1F0 E9ACCF62 DC5540B4 55A5C038 5E7621EC
  6B5550BF 71D5DCC1 DF59399E 183F71D4 06240A
        quit
!
!
username bhenry privilege 15 secret 5 $1$IA.c$nju.tP/VRiVEW8p60nAJp/
username admin privilege 15 secret 5 $1$ACfi$/tPweWKLwbCH/hHi2HPlm/
archive
 log config
  hidekeys
!
!
controller E1 0/0/0
 pri-group timeslots 1-16
!
controller E1 0/1/0
!
!
!
!
!
interface GigabitEthernet0/0
 description LAN Gateway Interface
 ip address 192.168.1.250 255.255.255.0
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.168.1.250
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bchan-number-order ascending
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
 translation-profile incoming Inbound
 cptone GB
 timeouts interdigit 2
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
dial-peer voice 9 pots
 destination-pattern 9T
 progress_ind setup enable 3
 progress_ind alert enable 8
 progress_ind progress enable 8
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 4000 voip
 destination-pattern 4...
 voice-class codec 1
 voice-class h323 1
 session target ipv4:192.168.1.2
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 4001 voip
 description VoIP Calls to SRST
 preference 2
 destination-pattern 4...
 voice-class codec 1
 voice-class h323 1
 session target ipv4:192.168.1.250
 dtmf-relay h245-alphanumeric
!
dial-peer voice 999 pots
 destination-pattern 999
 port 0/0/0:15
 forward-digits all
!
dial-peer voice 9999 pots
 destination-pattern 9999
 port 0/0/0:15
 forward-digits 3
!
dial-peer voice 4002 voip
 description =* T.38 FAX server using H.323 *=
 destination-pattern 4299
 voice-class h323 1
 session target ipv4:192.168.1.5
 session transport udp
 codec g711ulaw
!
dial-peer voice 6 pots
 description - National Fax
 numbering-type national
 destination-pattern 60[1-9]T
 port 0/0/0:15
!
dial-peer voice 7 pots
 description International Fax
 destination-pattern 700T
 port 0/0/0:15
 Prefix 00
!
!
no dial-peer outbound status-check pots
!
call-manager-fallback
 max-conferences 3 gain -6
 transfer-system full-consult
 ip source-address 192.168.1.250 port 2000
 max-ephones 48
 max-dn 96
 dialplan-pattern 1 02075394... extension-length 4
 alias 1 4051 to 4350
!
!
line con 0
 login local
line aux 0
line vty 0 4
 login local
 length 0
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
end
0
 
LVL 6

Expert Comment

by:greekstones
ID: 24394216
also try this for me please

1 enable

2. configure terminal

3. voice service voip

4. fax protocol t38 nse force

5. fax protocol cisco

6. fax-relay sg3-to-g3

7. end
0
 

Accepted Solution

by:
KS_BHENRY earned 0 total points
ID: 24394243
Just Figured it out...

Gateway was selecting Type national instead of International, so Forced isdn Map to unkown, and it works!!

Thanks for all help anyways!
0
 
LVL 6

Expert Comment

by:greekstones
ID: 24394255
hi again

about

dial-peer voice 4002 voip
 description =* T.38 FAX server using H.323 *=
 destination-pattern 4299
 voice-class h323 1
 session target ipv4:192.168.1.5
 session transport udp
 codec g711ulaw

is that the fax number 4299 that are you having problems with ?.
0
 
LVL 6

Expert Comment

by:greekstones
ID: 24394270
ah ok cool so was that a collmanager CCS issue

0
 

Author Comment

by:KS_BHENRY
ID: 24394282
Gateway issue, the fax server sends voip direct to gateway!
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Join & Write a Comment

Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now